summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD47
-rw-r--r--aquaria-ose-git.install13
-rw-r--r--aquaria-ose.desktop10
4 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e91326baca9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = aquaria-ose-git
+ pkgdesc = A 2D fantasy underwater action-adventure game (improved engine, a.k.a. Open Source Edition)
+ pkgver = 1.1.3+g485.8d6b65c
+ pkgrel = 1
+ url = https://github.com/AquariaOSE/Aquaria
+ install = aquaria-ose-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = sdl2
+ depends = openal
+ depends = gcc-libs
+ conflicts = aquaria-hib-git
+ conflicts = aquaria-hib-hg
+ conflicts = aquaria
+ conflicts = aquaria-git
+ replaces = aquaria-hib-git
+ replaces = aquaria-hib-hg
+ replaces = aquaria
+ replaces = aquaria-git
+ source = git://github.com/AquariaOSE/Aquaria.git
+ source = aquaria-ose.desktop
+ md5sums = SKIP
+ md5sums = 8677297d97cee364ca63652503ed6e62
+
+pkgname = aquaria-ose-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94359a003fef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Sam S. <smls75@gmail.com>
+
+pkgname=aquaria-ose-git
+pkgver=1.1.3+g485.8d6b65c
+_basever=1.1.3
+pkgrel=1
+pkgdesc="A 2D fantasy underwater action-adventure game (improved engine a.k.a. Open Source Edition)"
+url='https://github.com/AquariaOSE/Aquaria'
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('sdl2' 'openal' 'gcc-libs')
+makedepends=('cmake')
+conflicts=('aquaria-hib-git' 'aquaria-hib-hg' 'aquaria' 'aquaria-git')
+replaces=('aquaria-hib-git' 'aquaria-hib-hg' 'aquaria' 'aquaria-git')
+install="$pkgname.install"
+
+source=('git://github.com/AquariaOSE/Aquaria.git' "aquaria-ose.desktop")
+md5sums=('SKIP' '8677297d97cee364ca63652503ed6e62')
+
+_gitname=Aquaria
+
+pkgver() {
+ cd $_gitname
+ # Automatically generate package version from git commit number
+ echo $_basever+g$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd $_gitname
+ cmake -DAQUARIA_DEFAULT_DATA_DIR=/usr/share/aquaria \
+ -DAQUARIA_USE_SDL2=1
+ make
+}
+
+package() {
+ cd $pkgdir
+
+ # Install executable
+ install -Dm755 "$srcdir/$_gitname/aquaria" usr/bin/aquaria
+
+ # Install some additional game files needed by the executable
+ mkdir -p usr/share/aquaria/override
+ cp -r "$srcdir/$_gitname"/{game_scripts,files}/* usr/share/aquaria/override
+
+ # Install desktop entry
+ install -Dm644 "$srcdir/$pkgname.desktop" usr/share/applications/$pkgname.desktop
+}
diff --git a/aquaria-ose-git.install b/aquaria-ose-git.install
new file mode 100644
index 000000000000..9f6ca17476b0
--- /dev/null
+++ b/aquaria-ose-git.install
@@ -0,0 +1,13 @@
+
+post_install() {
+ if (! pacman -Qqs '^aquaria-data' >/dev/null); then
+ echo "Note:"
+ echo " | This package only provides the game engine. You will also need to"
+ echo " | install the proprietary game data, using one of these packages:"
+ echo " | aquaria-data-hib .. if you own the Humble Bundle version"
+ fi
+}
+
+post_upgrade() {
+ post_install "$@"
+}
diff --git a/aquaria-ose.desktop b/aquaria-ose.desktop
new file mode 100644
index 000000000000..bb38c0ab69cf
--- /dev/null
+++ b/aquaria-ose.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Categories=Game;
+Name=Aquaria
+Comment=Bit Blot
+GenericName=2D Fantasy Action-Adventure
+Icon=aquaria
+Exec=/usr/bin/aquaria
+Terminal=false