summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
-rw-r--r--aquaria-ose.desktop4
-rw-r--r--aquaria-ose.install (renamed from aquaria-ose-git.install)6
4 files changed, 33 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e91326baca9..34ca7e8dd28c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
-pkgbase = aquaria-ose-git
- pkgdesc = A 2D fantasy underwater action-adventure game (improved engine, a.k.a. Open Source Edition)
- pkgver = 1.1.3+g485.8d6b65c
+pkgbase = aquaria-ose
+ pkgdesc = A 2D fantasy underwater action-adventure game (Open Source Edition of the engine = official v1.1.3 + many improvements)
+ pkgver = 1.002
pkgrel = 1
- url = https://github.com/AquariaOSE/Aquaria
- install = aquaria-ose-git.install
+ url = http://www.bit-blot.com/forum/index.php?topic=4313.0
+ install = aquaria-ose.install
arch = i686
arch = x86_64
license = GPL
@@ -11,18 +11,20 @@ pkgbase = aquaria-ose-git
depends = sdl2
depends = openal
depends = gcc-libs
+ optdepends = aquaria-data-hib: Game data from the Humble Bundle release
conflicts = aquaria-hib-git
conflicts = aquaria-hib-hg
conflicts = aquaria
conflicts = aquaria-git
+ conflicts = aquaria-ose-git
replaces = aquaria-hib-git
replaces = aquaria-hib-hg
replaces = aquaria
replaces = aquaria-git
- source = git://github.com/AquariaOSE/Aquaria.git
+ source = b86133f.tar.gz::https://github.com/AquariaOSE/Aquaria/tarball/b86133f
source = aquaria-ose.desktop
- md5sums = SKIP
- md5sums = 8677297d97cee364ca63652503ed6e62
+ md5sums = 970fb36585114c9b0ac6d34dfdc3de65
+ md5sums = 0d1457aa0fae8ded40c011a7d766e46f
-pkgname = aquaria-ose-git
+pkgname = aquaria-ose
diff --git a/PKGBUILD b/PKGBUILD
index 94359a003fef..7a7ca8ccf432 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,43 @@
# Maintainer: Sam S. <smls75@gmail.com>
-pkgname=aquaria-ose-git
-pkgver=1.1.3+g485.8d6b65c
-_basever=1.1.3
+pkgname=aquaria-ose
+pkgver=1.002
pkgrel=1
-pkgdesc="A 2D fantasy underwater action-adventure game (improved engine a.k.a. Open Source Edition)"
-url='https://github.com/AquariaOSE/Aquaria'
+_gitrev=b86133f
+pkgdesc="A 2D fantasy underwater action-adventure game (Open Source Edition of the engine = official v1.1.3 + many improvements)"
+url='http://www.bit-blot.com/forum/index.php?topic=4313.0'
arch=('i686' 'x86_64')
license=('GPL')
depends=('sdl2' 'openal' 'gcc-libs')
makedepends=('cmake')
-conflicts=('aquaria-hib-git' 'aquaria-hib-hg' 'aquaria' 'aquaria-git')
+optdepends=('aquaria-data-hib: Game data from the Humble Bundle release')
+conflicts=('aquaria-hib-git' 'aquaria-hib-hg' 'aquaria' 'aquaria-git' 'aquaria-ose-git')
replaces=('aquaria-hib-git' 'aquaria-hib-hg' 'aquaria' 'aquaria-git')
install="$pkgname.install"
-source=('git://github.com/AquariaOSE/Aquaria.git' "aquaria-ose.desktop")
-md5sums=('SKIP' '8677297d97cee364ca63652503ed6e62')
-
-_gitname=Aquaria
-
-pkgver() {
- cd $_gitname
- # Automatically generate package version from git commit number
- echo $_basever+g$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
-}
+source=("$_gitrev.tar.gz::https://github.com/AquariaOSE/Aquaria/tarball/$_gitrev"
+ "aquaria-ose.desktop")
+md5sums=('970fb36585114c9b0ac6d34dfdc3de65'
+ '0d1457aa0fae8ded40c011a7d766e46f')
+_folder=AquariaOSE-Aquaria-$_gitrev
build() {
- cd $_gitname
+ cd $_folder
cmake -DAQUARIA_DEFAULT_DATA_DIR=/usr/share/aquaria \
-DAQUARIA_USE_SDL2=1
make
}
package() {
- cd $pkgdir
+ cd "$pkgdir"
# Install executable
- install -Dm755 "$srcdir/$_gitname/aquaria" usr/bin/aquaria
+ install -Dm755 "$srcdir/"$_folder/aquaria usr/bin/aquaria
# Install some additional game files needed by the executable
mkdir -p usr/share/aquaria/override
- cp -r "$srcdir/$_gitname"/{game_scripts,files}/* usr/share/aquaria/override
+ cp -r "$srcdir"/$_folder/{game_scripts,files}/* usr/share/aquaria/override
# Install desktop entry
- install -Dm644 "$srcdir/$pkgname.desktop" usr/share/applications/$pkgname.desktop
+ install -Dm644 "$srcdir"/$pkgname.desktop usr/share/applications/$pkgname.desktop
}
diff --git a/aquaria-ose.desktop b/aquaria-ose.desktop
index bb38c0ab69cf..e1456f4f8a4d 100644
--- a/aquaria-ose.desktop
+++ b/aquaria-ose.desktop
@@ -2,8 +2,8 @@
Version=1.0
Type=Application
Categories=Game;
-Name=Aquaria
-Comment=Bit Blot
+Name=Aquaria OSE
+Comment=Bit Blot + community
GenericName=2D Fantasy Action-Adventure
Icon=aquaria
Exec=/usr/bin/aquaria
diff --git a/aquaria-ose-git.install b/aquaria-ose.install
index 9f6ca17476b0..6fa99dfc5ec2 100644
--- a/aquaria-ose-git.install
+++ b/aquaria-ose.install
@@ -2,9 +2,9 @@
post_install() {
if (! pacman -Qqs '^aquaria-data' >/dev/null); then
echo "Note:"
- echo " | This package only provides the game engine. You will also need to"
- echo " | install the proprietary game data, using one of these packages:"
- echo " | aquaria-data-hib .. if you own the Humble Bundle version"
+ echo " | This package only provides the game engine. You will also"
+ echo " | need to install the proprietary game data, using one of the"
+ echo " | aquaria-data-* packages."
fi
}