summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34ca7e8dd28c..b497d96a07bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Mon Feb 15 10:12:39 UTC 2016
pkgbase = aquaria-ose
- pkgdesc = A 2D fantasy underwater action-adventure game (Open Source Edition of the engine = official v1.1.3 + many improvements)
- pkgver = 1.002
+ pkgdesc = A 2D fantasy underwater action-adventure game (Open Source Edition of the engine = original v1.1.3 + many improvements)
+ pkgver = 1.1.3+o1.002
pkgrel = 1
url = http://www.bit-blot.com/forum/index.php?topic=4313.0
install = aquaria-ose.install
@@ -21,9 +23,9 @@ pkgbase = aquaria-ose
replaces = aquaria-hib-hg
replaces = aquaria
replaces = aquaria-git
- source = b86133f.tar.gz::https://github.com/AquariaOSE/Aquaria/tarball/b86133f
+ source = https://github.com/AquariaOSE/Aquaria/archive/OSE-v1.002.tar.gz
source = aquaria-ose.desktop
- md5sums = 970fb36585114c9b0ac6d34dfdc3de65
+ md5sums = edb90261243611a20130b4bd9c2d6a13
md5sums = 0d1457aa0fae8ded40c011a7d766e46f
pkgname = aquaria-ose
diff --git a/PKGBUILD b/PKGBUILD
index 7a7ca8ccf432..44b068f763b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Sam S. <smls75@gmail.com>
pkgname=aquaria-ose
-pkgver=1.002
+_osever=1.002
+pkgver=1.1.3+o$_osever
pkgrel=1
-_gitrev=b86133f
-pkgdesc="A 2D fantasy underwater action-adventure game (Open Source Edition of the engine = official v1.1.3 + many improvements)"
+pkgdesc="A 2D fantasy underwater action-adventure game (Open Source Edition of the engine = original v1.1.3 + many improvements)"
url='http://www.bit-blot.com/forum/index.php?topic=4313.0'
arch=('i686' 'x86_64')
license=('GPL')
@@ -15,15 +15,18 @@ conflicts=('aquaria-hib-git' 'aquaria-hib-hg' 'aquaria' 'aquaria-git' 'aquaria-o
replaces=('aquaria-hib-git' 'aquaria-hib-hg' 'aquaria' 'aquaria-git')
install="$pkgname.install"
-source=("$_gitrev.tar.gz::https://github.com/AquariaOSE/Aquaria/tarball/$_gitrev"
+_repo=Aquaria
+_tag=OSE-v$_osever
+source=("https://github.com/AquariaOSE/$_repo/archive/$_tag.tar.gz"
"aquaria-ose.desktop")
-md5sums=('970fb36585114c9b0ac6d34dfdc3de65'
+md5sums=('edb90261243611a20130b4bd9c2d6a13'
'0d1457aa0fae8ded40c011a7d766e46f')
-_folder=AquariaOSE-Aquaria-$_gitrev
+_folder=$_repo-$_tag
build() {
cd $_folder
cmake -DAQUARIA_DEFAULT_DATA_DIR=/usr/share/aquaria \
+ -DAQUARIA_OVERRIDE_VERSION_STRING="Aquaria OSE $_osever (based on Aquaria v1.1.3)" \
-DAQUARIA_USE_SDL2=1
make
}