summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85dc07465220..4d4cd0d071f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Feb 15 17:21:33 UTC 2016
+# Sun Jun 19 20:19:19 UTC 2016
pkgbase = aquaria-ose
pkgdesc = A 2D fantasy underwater action-adventure game (Open Source Edition of the engine = original v1.1.3 + many improvements)
pkgver = 1.1.3+o1.002
diff --git a/PKGBUILD b/PKGBUILD
index ca9f149b094f..c97b2abe9714 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,9 +26,12 @@ _folder="$_repo-$_tag"
build() {
cd $_folder
- # Patch (TODO: remove post-1.002)
+ # Patch (TODO: remove post 1.002, it's already fixed in master)
awk -i inplace '{ print (102 == NR ? "// " : ""), $0; }' Aquaria/Main.cpp
+ # Make it compile with GCC 6.x
+ export CXXFLAGS="$CXXFLAGS -fpermissive"
+
# Compile
cmake -DAQUARIA_DEFAULT_DATA_DIR=/usr/share/aquaria \
-DAQUARIA_EXTRA_DATA_DIR=/usr/share/aquaria/override \