summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e6a6ba45f6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = arc
+ pkgdesc = Arc file archiver and compressor. Long since superceeded by zip/unzip but useful if have old .arc files need to unpack.
+ pkgver = 5.21p
+ pkgrel = 2
+ url = http://sourceforge.net/projects/arc
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = http://download.sourceforge.net/arc/arc-5.21p.tar.gz
+ sha1sums = 902ce24b23422880d474df6f1d9eba5e
+
+pkgname = arc
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67fddfe47bcb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Contributor: Diogo Leal <estranho@diogoleal.com>
+
+pkgname=arc
+pkgver=5.21p
+pkgrel=2
+pkgdesc="Arc file archiver and compressor. Long since superceeded by zip/unzip but useful if have old .arc files need to unpack."
+arch=('i686' 'x86_64')
+url='http://sourceforge.net/projects/arc'
+license=('GPL')
+source=("http://download.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha1sums=('902ce24b23422880d474df6f1d9eba5e')
+
+build() {
+ make -C "${pkgname}-${pkgver}"
+}
+
+package() {
+ make -C "${pkgname}-${pkgver}" PREFIX=/usr DESTDIR="${pkgdir}" install
+}