summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--lcg.patch12
3 files changed, 21 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9c8564a17d4..d73e5714cdf7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Sat Jul 22 16:09:52 UTC 2017
pkgbase = arc_unpacker-git
pkgdesc = CLI tool for extracting images and sounds from visual novels.
pkgver = r2426.b9843a13
@@ -17,7 +15,9 @@ pkgbase = arc_unpacker-git
provides = arc_unpacker
conflicts = arc_unpacker
source = arc_unpacker-git::git+https://github.com/vn-tools/arc_unpacker.git
- md5sums = SKIP
+ source = lcg.patch
+ sha256sums = SKIP
+ sha256sums = 37f3c1f1969ec9ed537a5cff79e3eb712fb2f317fcf99508eaa8bb250104a003
pkgname = arc_unpacker-git
diff --git a/PKGBUILD b/PKGBUILD
index fe80c43182af..82c60ad8e060 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,10 @@ optdepends=('libwebp')
makedepends=('boost')
provides=('arc_unpacker-git' 'arc_unpacker')
conflicts=('arc_unpacker')
-source=("$pkgname::git+https://github.com/vn-tools/arc_unpacker.git")
-md5sums=('SKIP')
+source=("$pkgname::git+https://github.com/vn-tools/arc_unpacker.git"
+ 'lcg.patch')
+sha256sums=('SKIP'
+ '37f3c1f1969ec9ed537a5cff79e3eb712fb2f317fcf99508eaa8bb250104a003')
pkgver() {
cd "$pkgname"
@@ -26,6 +28,8 @@ prepare() {
sed -i "s|\/\.\.\/|\/|g" CMakeLists.txt
# FIX etc/ path
sed -i "s|program\_path\.parent()|io\:\:path(\"/usr/share/${_pkgname}\")|g" src/io/program_path.cc
+ # FIX logic_error
+ git apply "$srcdir/lcg.patch"
}
build() {
diff --git a/lcg.patch b/lcg.patch
new file mode 100644
index 000000000000..37a670b38001
--- /dev/null
+++ b/lcg.patch
@@ -0,0 +1,12 @@
+diff --git a/src/algo/crypt/lcg.cc b/src/algo/crypt/lcg.cc
+index 6c2a7945..66630a08 100644
+--- a/src/algo/crypt/lcg.cc
++++ b/src/algo/crypt/lcg.cc
+@@ -17,6 +17,7 @@
+
+ #include "algo/crypt/lcg.h"
+ #include <functional>
++#include <stdexcept>
+
+ using namespace au;
+ using namespace au::algo::crypt;