summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--0001-fix-build-werror.patch12
-rw-r--r--PKGBUILD18
3 files changed, 29 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 77fa0f9cf5d6..122840a455a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = arcan-git
pkgdesc = Game Engine meets a Display Server meets a Multimedia Framework
- pkgver = 0.5.4.6.r10.gdb2f991e
+ pkgver = r4353.ad9686c7
pkgrel = 1
url = https://arcan-fe.com/
+ arch = aarch64
arch = x86_64
license = GPL2
license = LGPL
@@ -22,10 +23,12 @@ pkgbase = arcan-git
depends = openal
depends = ffmpeg
depends = apr
+ depends = wayland-protocols
provides = arcan
conflicts = arcan
source = arcan-git::git+https://github.com/letoram/arcan.git
+ source = 0001-fix-build-werror.patch
+ sha512sums = SKIP
sha512sums = SKIP
pkgname = arcan-git
-
diff --git a/0001-fix-build-werror.patch b/0001-fix-build-werror.patch
new file mode 100644
index 000000000000..0ce412bef2e6
--- /dev/null
+++ b/0001-fix-build-werror.patch
@@ -0,0 +1,12 @@
+--- a/arcan-git/src/CMakeLists.txt
++++ b/arcan-git/src/CMakeLists.txt
+@@ -225,7 +225,8 @@ if ("${CMAKE_C_COMPILER_ID}" MATCHES "GN
+ -Wno-unused-value
+ -Wno-unused-variable
+ -Wno-unused-result
+- -Wformat=0
++ -Wno-error=format-security
++ -Wno-format
+ )
+
+ elseif ("${CMAKE_C_COMPILER_ID}" MATCHES "Clang" AND NOT ENABLE_WALL_SPAM)
diff --git a/PKGBUILD b/PKGBUILD
index 7fcfe81dd777..9df8eb7ddb0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
pkgdesc='Game Engine meets a Display Server meets a Multimedia Framework'
pkgname='arcan-git'
-pkgver=0.5.4.6.r10.gdb2f991e
+pkgver=r4353.ad9686c7
pkgrel=1
license=('GPL2' 'LGPL' 'custom:BSD')
-arch=('x86_64')
+arch=(aarch64 'x86_64')
depends=('freetype2' 'harfbuzz' 'harfbuzz-icu' 'mesa' 'luajit' 'sqlite'
- 'libxkbcommon' 'libvncserver' 'libusb' 'openal' 'ffmpeg' 'apr')
+ 'libxkbcommon' 'libvncserver' 'libusb' 'openal' 'ffmpeg' 'apr' 'wayland-protocols')
makedepends=('cmake' 'ruby' 'git')
provides=('arcan')
conflicts=('arcan')
url='https://arcan-fe.com/'
-source=("${pkgname}::git+https://github.com/letoram/arcan.git")
-sha512sums=('SKIP')
+source=("${pkgname}::git+https://github.com/letoram/arcan.git"
+ "0001-fix-build-werror.patch")
+sha512sums=('SKIP' 'SKIP')
pkgver () {
cd "${pkgname}"
@@ -23,6 +24,11 @@ pkgver () {
)
}
+prepare () {
+ cd "${srcdir}"
+ patch -Np1 -i 0001-fix-build-werror.patch
+}
+
build () {
pushd "${pkgname}/doc" &> /dev/null
ruby docgen.rb mangen
@@ -35,7 +41,7 @@ build () {
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DVIDEO_PLATFORM=egl-dri \
- -DSHMIF_TUI_ACCEL=ON \
+ -DHYBRID_SDL=ON \
-DENABLE_LWA=ON \
-DENABLE_LTO=ON \
../src