summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
-rw-r--r--arcanist.install5
4 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7497ac0c880
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = arcanist-git
+ pkgdesc = Arcanist (commonly, "arc") is the command-line frontend to Phabricator
+ pkgver = conduit.5.693.ge4b1e8e
+ pkgrel = 1
+ url = http://phabricator.com
+ install = arcanist.install
+ arch = any
+ license = Apache
+ makedepends = git
+ depends = libphutil-git
+ provides = arcanist
+ source = git://github.com/facebook/arcanist.git
+ sha256sums = SKIP
+
+pkgname = arcanist-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..71a9d16c2b38
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*~
+*/
+*.tar.*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0882c99a5a7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Sergio Correia <sergio@correia.cc>
+# Contributor: Nicolas Vivet <nizzox@gmail.com>
+
+pkgname=arcanist-git
+_pkgname=arcanist
+pkgver=conduit.5.693.ge4b1e8e
+pkgrel=1
+pkgdesc='Arcanist (commonly, "arc") is the command-line frontend to Phabricator'
+arch=('any')
+url="http://phabricator.com"
+license=('Apache')
+depends=('libphutil-git')
+makedepends=('git')
+provides=('arcanist')
+install='arcanist.install'
+source=('git://github.com/facebook/arcanist.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --always | sed 's|-|.|g' # Use the tag of the last commit
+}
+
+package() {
+ install -Dd "${srcdir}"/usr/share/php/"${_pkgname}" "${pkgdir}"/etc/bash_completion.d "${pkgdir}"/usr/bin
+
+ # do not copy hidden directories
+ mkdir -p "${pkgdir}"/usr/share/php/"${_pkgname}"
+ cp -a "${srcdir}"/"${_pkgname}"/* "${pkgdir}"/usr/share/php/"${_pkgname}"/
+ ln -s ../../usr/share/php/"${_pkgname}"/resources/shell/bash-completion "${pkgdir}"/etc/bash_completion.d/"${_pkgname}"
+ ln -s ../share/php/"${_pkgname}"/bin/arc "${pkgdir}"/usr/bin/arc
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/arcanist.install b/arcanist.install
new file mode 100644
index 000000000000..84d4a0209cef
--- /dev/null
+++ b/arcanist.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo "You must add the path /usr/share/php to the open_basedir variable"
+ echo "of your /etc/php/php.ini configuration file in order to execute"
+ echo "the arc command."
+}