summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc526f09b29b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = archarm-mobile-fde-installer-git
+ pkgdesc = Script to setup Full-Ddisk-Encryption on Arch Linux ARM for PinePhone and PineTab
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/dreemurrs-embedded/archarm-mobile-fde-installer
+ arch = any
+ license = custom:none
+ depends = parted
+ depends = cryptsetup
+ depends = sudo
+ depends = wget
+ depends = tar
+ depends = squashfs-tools
+ depends = e2fsprogs
+ depends = f2fs-tools
+ depends = util-linux
+ depends = zstd
+ depends = curl
+ optdepends = gnupg: config import/export support
+ provides = archarm-mobile-fde-installer=1.0.0
+ source = git+https://github.com/dreemurrs-embedded/archarm-mobile-fde-installer.git
+ sha256sums = SKIP
+
+pkgname = archarm-mobile-fde-installer-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b50fc3083d21
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Dreemurrs Embedded Labs
+pkgname=archarm-mobile-fde-installer-git
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Script to setup Full-Ddisk-Encryption on Arch Linux ARM for PinePhone and PineTab'
+arch=('any')
+url='https://github.com/dreemurrs-embedded/archarm-mobile-fde-installer'
+license=('custom:none')
+depends=('git' 'openssl')
+optdepends=('gnupg: config import/export support')
+source=("git+https://github.com/dreemurrs-embedded/archarm-mobile-fde-installer.git")
+sha256sums=('SKIP')
+provides=("archarm-mobile-fde-installer=${pkgver}")
+depends=(
+ 'parted'
+ 'cryptsetup'
+ 'sudo'
+ 'wget'
+ 'tar'
+ 'squashfs-tools'
+ 'e2fsprogs'
+ 'f2fs-tools'
+ 'util-linux'
+ 'zstd'
+ 'curl'
+)
+
+package() {
+ cd "archarm-mobile-fde-installer/"
+ install -m 755 -D installer.sh "${pkgdir}/usr/bin/archarm-mobile-fde-installer"
+}