summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore3
-rw-r--r--Makefile19
3 files changed, 23 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e20315553fe8..4570a936c9cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = archc-git
pkgdesc = A powerful and modern open-source architecture description language
- pkgver = v0.1
+ pkgver = 2.4.1.r71.gf0b697c
pkgrel = 1
url = https://github.com/ArchC/ArchC
arch = x86_64
arch = i686
license = GPL
makedepends = git
- depends = systemc
+ makedepends = systemc
+ depends = bash
provides = archc
conflicts = archc
source = git+https://github.com/ArchC/ArchC.git
diff --git a/.gitignore b/.gitignore
index ef1c516c0ef3..6c8bc094eaa2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,7 @@
*.pkg*
+*.log
+*.tar.*
/ArchC
/pkg
/src
+/systemc
diff --git a/Makefile b/Makefile
index 530ee439c38d..b2a6fee7ffa9 100644
--- a/Makefile
+++ b/Makefile
@@ -3,8 +3,23 @@ all: .SRCINFO
.SRCINFO: PKGBUILD
makepkg --printsrcinfo > .SRCINFO
-test:
+test: systemc
+ testing-x86_64-build -c -- -n -I systemc/systemc-*.pkg*
+
+quick-test:
makepkg -sf
namcap archc-git-*.pkg*
-.PHONY: all clean test
+systemc:
+ # Make systemc dependency from AUR
+ if [ ! -f systemc/systemc-*.pkg* ] ; then \
+ rm -rf systemc/ && \
+ wget https://aur.archlinux.org/cgit/aur.git/snapshot/systemc.tar.gz && \
+ tar xf systemc.tar.gz && \
+ cd systemc && makepkg ;\
+ fi
+
+clean:
+ rm -rf ArchC/ pkg/ src/ systemc/ *.log archc-git-*.pkg*
+
+.PHONY: all test quick-test systemc clean