summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
-rw-r--r--python27.patch19
3 files changed, 30 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94268835e869..0b2b0ea022a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,9 +2,9 @@
# Fri Apr 1 10:24:42 UTC 2016
pkgbase = archey2
pkgdesc = Simple python script that displays the arch logo and some basic information. Python 2.x version
- pkgver = 2019.10.7
+ pkgver = 20121013
pkgrel = 2
- url = https://github.com/XdaemonX/archey
+ url = http://github.com/djmelik/archey
arch = i686
arch = x86_64
license = GPL
@@ -13,7 +13,8 @@ pkgbase = archey2
provides = archey
conflicts = archey3
conflicts = archey
- md5sums = cadd2230de52758f401ecb7852c417cc
+ source = python27.patch
+ md5sums = d5a4b8f4b71379b869a12879199b0b38
pkgname = archey2
diff --git a/PKGBUILD b/PKGBUILD
index b03fc76dd259..2f68757c8fa2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
-# Maintainer: Erhad Husovic <xdaemonx@protonmail.ch>
+# Contributor: Melik Ludwig Manukyan <melik@archlinux.us>
pkgname=archey2
-pkgver=2019.10.7
+pkgver=20121013
pkgrel=2
pkgdesc="Simple python script that displays the arch logo and some basic information. Python 2.x version"
arch=('i686' 'x86_64')
-url="https://github.com/XdaemonX/archey"
+url="http://github.com/djmelik/archey"
license=('GPL')
depends=('python2')
makedepends=('git')
provides=('archey')
conflicts=('archey3' 'archey')
+source=('python27.patch')
-_gitroot="https://github.com/XdaemonX/archey.git"
+_gitroot="git://github.com/djmelik/archey.git"
_gitname="archey"
package() {
@@ -32,8 +33,9 @@ package() {
msg "Starting make..."
cd ${srcdir}/archey
+ patch -p1 -i ${srcdir}/python27.patch
install -D -m755 archey ${pkgdir}/usr/bin/archey || return 1
install -D -m644 COPYING ${pkgdir}/usr/share/licenses/archey/COPYING
}
-md5sums=('cadd2230de52758f401ecb7852c417cc')
+md5sums=('d5a4b8f4b71379b869a12879199b0b38')
diff --git a/python27.patch b/python27.patch
new file mode 100644
index 000000000000..2cb923602616
--- /dev/null
+++ b/python27.patch
@@ -0,0 +1,19 @@
+--- bin/archey 2012-10-13 01:04:18.000000000 +0300
++++ bin/archey 2012-10-13 01:10:07.008684591 +0300
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python3
++#!/usr/bin/env python2
+ #
+ # Archey [version 0.3.0]
+ #
+@@ -91,8 +91,8 @@
+ \x1b[0m'''
+ }
+
+-processes = str(subprocess.check_output(('ps', '-u', getuser(), '-o', 'comm',
+- '--no-headers')), encoding='utf8').rstrip('\n').split('\n')
++processes = str(subprocess.check_output(('ps', '-u', getuser(), '-o', 'comm',
++ '--no-headers'))).rstrip('\n').split('\n')
+
+ #---------------Classes---------------#
+