summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD27
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..caee5ac2c29b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = archfetch
+ pkgdesc = Neofetch, but simplified. For Arch Linux.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/xxczaki/archfetch/
+ arch = i686
+ arch = x86_64
+ license = MIT
+
+pkgname = archfetch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a9e0511b0a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+
+
+# Maintainer: Antoni Kepinski <hello[at]akepinski[dot]me>
+pkgname=archfetch
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Neofetch, but simplified. For Arch Linux."
+url="https://github.com/xxczaki/archfetch/"
+arch=('i686' 'x86_64')
+license=('MIT')
+depends=()
+makedepens=('git')
+source=()
+
+package() {
+ cd "${PKGMK_SOURCE_DIR}"
+
+ if cd "${pkgname}"; then
+ git fetch -q
+ git reset --hard origin/master
+ else
+ git clone https://github.com/xxczaki/archfetch "${pkgname}"
+ cd "${pkgname}"
+ fi
+
+ install -Dm755 archfetch-crux "${PKG}/usr/bin/archfetch"
+}