summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--ArchiSteamFarm-bin.desktop8
-rw-r--r--PKGBUILD26
3 files changed, 16 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fbda2b875a2..7323a1ed354e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = archisteamfarm-bin
pkgdesc = C# application that allows you to farm steam cards using multiple steam accounts simultaneously.
pkgver = 6.0.1.24
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/JustArchiNET/ArchiSteamFarm
arch = x86_64
license = Apache
@@ -9,12 +9,10 @@ pkgbase = archisteamfarm-bin
makedepends = curl
makedepends = jq
depends = dotnet-runtime
- noextract = ASF-linux-x64.zip
+ noextract = archisteamfarm-6.0.1.24.zip
options = !strip
options = staticlibs
- source = archisteamfarm-bin-6.0.1.24.zip::https://github.com/JustArchiNET/ArchiSteamFarm/releases/download/6.0.1.24/ASF-linux-x64.zip
- source = ArchiSteamFarm-bin.desktop
+ source = archisteamfarm-6.0.1.24.zip::https://github.com/JustArchiNET/ArchiSteamFarm/releases/download/6.0.1.24/ASF-linux-x64.zip
sha512sums = 76832ee156a6fb895d64dd1ae7b1dace6413e1acf208c54ed3a7a0dde301a6a91b36aef89508220f27fe7a03bee07525ef08eaed00c44ccfda4608bd020632e4
- sha512sums = 32aaead4aacc02c9c60afef74e04cb3a30afc4d76f5e6836a05e672344c7db66cf099849cb2bc9a04454a026f99c9f60d3d7186f4a496d4626fe1a3d40d4ecf6
pkgname = archisteamfarm-bin
diff --git a/ArchiSteamFarm-bin.desktop b/ArchiSteamFarm-bin.desktop
deleted file mode 100644
index e78307c73801..000000000000
--- a/ArchiSteamFarm-bin.desktop
+++ /dev/null
@@ -1,8 +0,0 @@
-[Desktop Entry]
-Name=ArchiSteamFarm
-Comment="C# application that allows you to farm steam cards using multiple steam accounts simultaneously."
-Exec=/opt/ArchiSteamFarm-bin/ArchiSteamFarm
-Icon=/opt/ArchiSteamFarm-bin/ArchiSteamFarm.ico
-Terminal=true
-Type=Application
-Categories=Game;
diff --git a/PKGBUILD b/PKGBUILD
index 9b7c5bd2025b..77cf9cac6e3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,33 @@
# Maintainer: Jat <chat@jat.email>
-pkgname=archisteamfarm-bin
+_pkgname=archisteamfarm
+pkgname="${_pkgname}-bin"
pkgver=6.0.1.24
-pkgrel=1
+pkgrel=2
pkgdesc='C# application that allows you to farm steam cards using multiple steam accounts simultaneously.'
arch=('x86_64')
url='https://github.com/JustArchiNET/ArchiSteamFarm'
license=('Apache')
depends=('dotnet-runtime')
makedepends=('unzip' 'curl' 'jq')
-noextract=('ASF-linux-x64.zip')
+noextract=("${_pkgname}-${pkgver}.zip")
options=('!strip' 'staticlibs')
source=(
- "${pkgname}-${pkgver}.zip::${url}/releases/download/${pkgver}/ASF-linux-x64.zip"
- "ArchiSteamFarm-bin.desktop"
+ "${_pkgname}-${pkgver}.zip::${url}/releases/download/${pkgver}/ASF-linux-x64.zip"
+)
+sha512sums=(
+ '76832ee156a6fb895d64dd1ae7b1dace6413e1acf208c54ed3a7a0dde301a6a91b36aef89508220f27fe7a03bee07525ef08eaed00c44ccfda4608bd020632e4'
)
-
-sha512sums=('76832ee156a6fb895d64dd1ae7b1dace6413e1acf208c54ed3a7a0dde301a6a91b36aef89508220f27fe7a03bee07525ef08eaed00c44ccfda4608bd020632e4'
- '32aaead4aacc02c9c60afef74e04cb3a30afc4d76f5e6836a05e672344c7db66cf099849cb2bc9a04454a026f99c9f60d3d7186f4a496d4626fe1a3d40d4ecf6')
prepare() {
- unzip "${pkgname}-${pkgver}.zip" -d "ASF"
+ unzip "${_pkgname}-${pkgver}.zip" -d "${_pkgname}-${pkgver}"
}
package() {
- install -Dm644 -t "${pkgdir}/usr/share/applications" "ArchiSteamFarm-bin.desktop"
+ mkdir -p "${pkgdir}/opt" "${pkgdir}/usr/share/applications"
- install -d "${pkgdir}/opt/ArchiSteamFarm-bin"
- cp -r "${srcdir}/ASF"/* "${pkgdir}/opt/ArchiSteamFarm-bin/"
- install -Dm755 -t "${pkgdir}/opt/ArchiSteamFarm-bin" "${srcdir}/ASF/ArchiSteamFarm"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ chmod a+w config logs
+ cp -a . "${pkgdir}/opt/${_pkgname}"
}