summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 600109a22a73..517fe4906473 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = arcus
pkgdesc = Communication library between internal components for Ultimaker software
pkgver = 5.0.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/Ultimaker/libArcus
arch = x86_64
license = LGPL
@@ -10,6 +10,8 @@ pkgbase = arcus
makedepends = ninja
depends = python
depends = protobuf
+ provides = libarcus
+ conflicts = libarcus
options = debug
source = arcus-5.0.0.tar.gz::https://github.com/Ultimaker/libArcus/archive/5.0.0.tar.gz
source = protobuf-3.18.patch
diff --git a/PKGBUILD b/PKGBUILD
index 170e5cb07f33..25b3c39aaffd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,18 @@
-# Maintainer: Jelle van der Waa <jelle@archlinux.org>
-# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Maintainer: TimTechDev <archlinux [at] timtechdev [dot] de>
+# Contributor: Jelle van der Waa <jelle@archlinux.org>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: Grey Christoforo <first name [at] last name [dot] net>
# upstreamed renamed to libarcus
pkgname=arcus
pkgver=5.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="Communication library between internal components for Ultimaker software"
url="https://github.com/Ultimaker/libArcus"
arch=('x86_64')
license=('LGPL')
+provides=('libarcus')
+conflicts=('libarcus')
makedepends=('cmake' 'git' 'ninja')
depends=('python' 'protobuf')
options=('debug')
@@ -30,6 +33,9 @@ prepare() {
}
build() {
+ export _sitelib="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ source .venv/bin/activate
+
cmake -S libArcus-${pkgver} -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \