summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD29
-rw-r--r--arduino.desktop12
-rw-r--r--arduino.install3
-rw-r--r--arduino.xml44
5 files changed, 19 insertions, 72 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f3f5b091974..b73455a4c1e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = arduino
pkgdesc = Arduino prototyping platform SDK
pkgver = 1.6.9
- pkgrel = 1
+ pkgrel = 2
url = https://arduino.cc/en/Main/Software
install = arduino.install
arch = i686
@@ -13,6 +13,7 @@ pkgbase = arduino
depends = gtk2
depends = desktop-file-utils
depends = shared-mime-info
+ depends = avrdude
options = !strip
options = staticlibs
source_i686 = https://downloads.arduino.cc/arduino-1.6.9-linux32.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index a173632bbc50..c14947e53fbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Christopher Loen <christopherloen at gmail dot com>
+# Co-Maintainer: NicoHood <aur {at} nicohood {dot} de>
# Contributor: Peter Reschenhofer <peter.reschenhofer@gmail.com>
# Contributor: Niels Martignène <niels.martignene@gmail.com>
# Contributor: PyroPeter <googlemail.com@abi1789>
# Contributor: darkapex <me@jailuthra.in>
# Contributor: tty0 <vt.tty0[d0t]gmail.com>
-
-pkgname='arduino'
-pkgver='1.6.9'
-pkgrel=1
+pkgname=arduino
+pkgver=1.6.9
+pkgrel=2
pkgdesc="Arduino prototyping platform SDK"
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="https://arduino.cc/en/Main/Software"
options=(!strip staticlibs)
license=('GPL' 'LGPL')
-depends=('gtk2' 'desktop-file-utils' 'shared-mime-info')
+depends=('gtk2' 'desktop-file-utils' 'shared-mime-info' 'avrdude')
install="arduino.install"
source_i686=("https://downloads.arduino.cc/arduino-${pkgver}-linux32.tar.xz")
source_x86_64=("https://downloads.arduino.cc/arduino-${pkgver}-linux64.tar.xz")
@@ -32,25 +32,26 @@ package() {
install -dm755 "${pkgdir}/usr/bin"
install -dm755 "${pkgdir}/usr/share/"{doc,icons/hicolor,applications,mime/packages}
- # copy the whole SDK to /usr/share/arduino/
- cp -rf . "${pkgdir}/usr/share/arduino/"
+ # Copy the whole SDK
+ cp -a . "${pkgdir}/usr/share/arduino"
+ # Create symlinks
ln -s /usr/share/arduino/arduino "${pkgdir}/usr/bin/arduino"
ln -s /usr/share/arduino/reference "${pkgdir}/usr/share/doc/arduino"
- # fix avrdude
+ # fix avrdude (see https://github.com/arduino/Arduino/issues/5094)
rm -f "${pkgdir}/usr/share/arduino/hardware/tools/avr/bin/avrdude"{,_bin}
ln -s /usr/bin/avrdude "${pkgdir}/usr/share/arduino/hardware/tools/avr/bin/avrdude"
- # desktop icon
+ # Install desktop icons (keep a symlink for the arduino binary)
cp -a lib/icons/* "${pkgdir}/usr/share/icons/hicolor"
rm -rf "${pkgdir}/usr/share/arduino/lib/icons"
ln -s /usr/share/icons/hicolor "${pkgdir}/usr/share/arduino/lib/icons"
- #create desktop file using existing template
- sed "s,<BINARY_LOCATION>,arduino %U,g;s,<ICON_NAME>,arduino,g" "lib/desktop.template" > "${pkgdir}/usr/share/applications/arduino.desktop"
+ # Create desktop file using existing template
+ sed "s,<BINARY_LOCATION>,arduino %U,g;s,<ICON_NAME>,arduino,g" "lib/desktop.template" \
+ > "${pkgdir}/usr/share/applications/arduino.desktop"
- # desktop and mimetype files
- install -m644 "${srcdir}/arduino.desktop" "${pkgdir}/usr/share/applications/"
- install -m644 "${srcdir}/arduino.xml" "${pkgdir}/usr/share/mime/packages/"
+ # Install Arduino mime type
+ ln -s /usr/share/arduino/lib/arduino-arduinoide.xml "${pkgdir}/usr/share/mime/packages/arduino.xml"
}
diff --git a/arduino.desktop b/arduino.desktop
deleted file mode 100644
index 38efd0b0b793..000000000000
--- a/arduino.desktop
+++ /dev/null
@@ -1,12 +0,0 @@
-[Desktop Entry]
-Name=Arduino
-GenericName=Arduino IDE
-Comment=The open-source Arduino environment
-TryExec=arduino
-Exec=arduino %U
-Icon=arduino
-Type=Application
-Terminal=false
-MimeType=text/x-arduino;
-Categories=Development;
-StartupWMClass=processing-app-Base
diff --git a/arduino.install b/arduino.install
index 4015160bfaa9..9a2794a97038 100644
--- a/arduino.install
+++ b/arduino.install
@@ -1,3 +1,4 @@
post_install() {
- echo "Don't forget to add yourself to the uucp and lock groups: gpasswd -a <user> uucp && gpasswd -a <user> lock (execute as root)"
+ echo "Add yourself to the uucp group to access the serial ports:"
+ echo "sudo usermod -a -G uucp <user>"
}
diff --git a/arduino.xml b/arduino.xml
deleted file mode 100644
index 166b5a245f30..000000000000
--- a/arduino.xml
+++ /dev/null
@@ -1,44 +0,0 @@
-<?xml version='1.0' encoding='utf-8'?>
-<!-- Copied from the Ubuntu package -->
-<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
- <mime-type type="text/x-arduino">
- <comment>Arduino source code</comment>
- <comment xml:lang="ara">شفرة مصدر Arduino</comment>
- <comment xml:lang="be@latin">Kryničny kod Arduino</comment>
- <comment xml:lang="bg">Изходен код на Arduino</comment>
- <comment xml:lang="ca">codi font en Arduino</comment>
- <comment xml:lang="da">Arduinokildekode</comment>
- <comment xml:lang="de">Arduino-Quelltext</comment>
- <comment xml:lang="el">πηγαίος κώδικας Arduino</comment>
- <comment xml:lang="en_GB">Arduino source code</comment>
- <comment xml:lang="eo">Arduino-fontkodo</comment>
- <comment xml:lang="es">código fuente en Arduino</comment>
- <comment xml:lang="eu">Arduino iturburu-kodea</comment>
- <comment xml:lang="fi">Arduino-lähdekoodi</comment>
- <comment xml:lang="fr">code source Arduino</comment>
- <comment xml:lang="ga">cód foinseach Arduino</comment>
- <comment xml:lang="hu">Arduino-forráskód</comment>
- <comment xml:lang="id">Kode program Arduino</comment>
- <comment xml:lang="it">Codice sorgente Arduino</comment>
- <comment xml:lang="ja">Arduino ソースコード</comment>
- <comment xml:lang="lt">Arduino pradinis kodas</comment>
- <comment xml:lang="lv">Arduino pirmkods</comment>
- <comment xml:lang="ms">Kod sumber Arduino</comment>
- <comment xml:lang="nb">Arduino-kildekode</comment>
- <comment xml:lang="nl">Arduino-broncode</comment>
- <comment xml:lang="nn">Arduino-kjeldekode</comment>
- <comment xml:lang="pl">Kod źródłowy Arduino</comment>
- <comment xml:lang="pt">código fonte Arduino</comment>
- <comment xml:lang="pt_BR">Código fonte Arduino</comment>
- <comment xml:lang="ru">исходный код Arduino</comment>
- <comment xml:lang="sq">Kod burues Arduino</comment>
- <comment xml:lang="sv">Arduino-källkod</comment>
- <comment xml:lang="uk">Вихідний код на мові Arduino</comment>
- <comment xml:lang="vi">Mã nguồn Arduino</comment>
- <comment xml:lang="zh_CN">Arduino 源代码</comment>
- <comment xml:lang="zh_TW">Arduino 源代碼</comment>
- <sub-class-of type="text/x-c++src"/>
- <glob pattern="*.ino"/>
- <glob pattern="*.pde"/>
- </mime-type>
-</mime-info>