summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be3e381d6436..40c4e82d7919 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,9 +5,7 @@ pkgbase = arduino-samd-core-rc
url = https://github.com/arduino/ArduinoCore-samd
arch = any
license = GPL
- depends = avrdude
- depends = avr-gcc
- depends = avr-libc
+ depends = arduino-ctags
provides = arduino-samd-core
conflicts = arduino-samd-core
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index 013ece551c22..5e2a2b4c55a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ url="https://github.com/arduino/ArduinoCore-samd"
license=('GPL')
provides=('arduino-samd-core')
conflicts=('arduino-samd-core')
-depends=('avrdude' 'avr-gcc' 'avr-libc') ## this needs to be fixed to include arm compiler
+depends=('arduino-ctags') ## this needs to be fixed to include the analogs to: avrdude, avr-gcc and avr-libc
options=(!strip !emptydirs)
source=("https://github.com/arduino/ArduinoCore-samd/archive/${pkgver}.tar.gz"
"platform.patch")
@@ -21,11 +21,13 @@ prepare()
mv "ArduinoCore-samd-${pkgver}" ${pkgname//-rc}-${pkgver}
cd "${srcdir}/${pkgname//-rc}-${pkgver}"
-
# Update version in patchfile, then apply it
sed -i "s/^version=.*/ version=${pkgver}/" "${srcdir}/platform.patch"
patch -Np1 -i "${srcdir}/platform.patch"
+ echo "tools.ctags.path=/usr/bin" >> platform.txt
+ echo "tools.ctags.cmd.path={path}/arduino-ctags" >> platform.txt
+
# Remove elf files
find . -name "*.elf" -type f -exec rm -f {} \;
find . -name "*.a" -type f -exec rm -f {} \;