summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--disable-update-check.patch11
3 files changed, 20 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 771e14adcf48..7c18f8409da2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = arduino10
pkgdesc = Arduino prototyping platform SDK (old version)
pkgver = 1.0.6
- pkgrel = 5
+ pkgrel = 6
epoch = 1
url = http://arduino.cc/en/Main/Software
install = arduino10.install
@@ -20,9 +20,11 @@ pkgbase = arduino10
source = arduino-fix-arguments.patch
source = arduino10.desktop
source = arduino10.xml
+ source = disable-update-check.patch
sha256sums = 631921fce485d14c79bcdc31d5d6f3a95d729d49975390b6b785fe49d238ff65
sha256sums = 00b6ab429a7f85fe4b2e571c08fea50f615d8e5b6b570797b01f293ff9bb57f8
sha256sums = 473b82156505e9bd903e4d8484e8d183f2e3bf3c1f7e29940b815929ae597b68
+ sha256sums = 7c05abf88596c362de4be7afeef5e310e9a70b7bbefef8af844f8c0dee2e7b3c
source_i686 = http://downloads.arduino.cc/arduino-1.0.6-linux32.tgz
sha256sums_i686 = f059a572231abafb92099a3a404c0a41502c3413668610676c40029384edc658
source_x86_64 = http://downloads.arduino.cc/arduino-1.0.6-linux64.tgz
diff --git a/PKGBUILD b/PKGBUILD
index 1985754673ab..efa5ff9f85cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=arduino10
epoch=1
pkgver=1.0.6
-pkgrel=5
+pkgrel=6
pkgdesc="Arduino prototyping platform SDK (old version)"
arch=('i686' 'x86_64')
url="http://arduino.cc/en/Main/Software"
@@ -17,12 +17,14 @@ makedepends=('icoutils')
install="arduino10.install"
source=('arduino-fix-arguments.patch'
'arduino10.desktop'
- 'arduino10.xml')
+ 'arduino10.xml'
+ 'disable-update-check.patch')
source_i686+=("http://downloads.arduino.cc/arduino-${pkgver}-linux32.tgz")
source_x86_64+=("http://downloads.arduino.cc/arduino-${pkgver}-linux64.tgz")
sha256sums=('631921fce485d14c79bcdc31d5d6f3a95d729d49975390b6b785fe49d238ff65'
'00b6ab429a7f85fe4b2e571c08fea50f615d8e5b6b570797b01f293ff9bb57f8'
- '473b82156505e9bd903e4d8484e8d183f2e3bf3c1f7e29940b815929ae597b68')
+ '473b82156505e9bd903e4d8484e8d183f2e3bf3c1f7e29940b815929ae597b68'
+ '7c05abf88596c362de4be7afeef5e310e9a70b7bbefef8af844f8c0dee2e7b3c')
sha256sums_i686=('f059a572231abafb92099a3a404c0a41502c3413668610676c40029384edc658')
sha256sums_x86_64=('1ff175c487de335981d3aad64cf212b56cb2c778a6bdd6655045335ffc65e147')
@@ -30,6 +32,7 @@ prepare() {
cd "arduino-${pkgver}"
patch -Np1 <"${srcdir}/arduino-fix-arguments.patch"
+ patch -Np1 <"${srcdir}/disable-update-check.patch"
icotool -x -o .. lib/arduino_icon.ico
}
diff --git a/disable-update-check.patch b/disable-update-check.patch
new file mode 100644
index 000000000000..14e34dc3a753
--- /dev/null
+++ b/disable-update-check.patch
@@ -0,0 +1,11 @@
+--- a/lib/preferences.txt 2014-09-16 15:42:47.000000000 +0200
++++ b/lib/preferences.txt 2016-04-29 15:01:28.940567416 +0200
+@@ -63,7 +63,7 @@
+ # by default, check the processing server for any updates
+ # (please avoid disabling, this also helps us know basic numbers
+ # on how many people are using Processing)
+-update.check = true
++update.check = false
+
+ # on windows, automatically associate .pde files with processing.exe
+ platform.auto_file_type_associations = true