summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7bc23c3005cb..bbaf86f6a8ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ardupilot-copter-sitl
pkgdesc = Advanced, Fully-Featured, and Reliable Autopilot Software (Copter, SITL)
- pkgver = 4.2.2
+ pkgver = 4.3.6
pkgrel = 1
url = https://ardupilot.org
arch = i686
@@ -26,7 +26,6 @@ pkgbase = ardupilot-copter-sitl
depends = csfml
depends = sfml
depends = python-yaml
- depends = python-argparse
depends = python-wxpython
depends = lcov
depends = gcovr
@@ -44,7 +43,7 @@ pkgbase = ardupilot-copter-sitl
depends = python-intelhex
depends = lsb-release
provides = ardupilot-sitl
- source = ardupilot-copter-sitl-4.2.2::git+https://github.com/ArduPilot/ardupilot.git#tag=Copter-4.2.2
+ source = ardupilot-copter-sitl-4.3.6::git+https://github.com/ArduPilot/ardupilot.git#tag=Copter-4.3.6
source = ardupilot-copter-sitl-libuavcan::git+https://github.com/DroneCAN/libuavcan.git
source = ardupilot-copter-sitl-waf::git+https://github.com/ArduPilot/waf.git
source = ardupilot-copter-sitl-benchmark::git+https://github.com/google/benchmark.git
@@ -57,7 +56,7 @@ pkgbase = ardupilot-copter-sitl
source = ardupilot-copter-sitl-pydronecan::git+https://github.com/DroneCAN/pydronecan.git
source = ardupilot-copter-sitl-dronecan_dsdlc::git+https://github.com/DroneCAN/dronecan_dsdlc.git
source = ardupilot-copter-sitl-libcanard::git+https://github.com/DroneCAN/libcanard.git
- source = uninitialized.patch::https://patch-diff.githubusercontent.com/raw/ArduPilot/ardupilot/pull/21183.patch
+ source = uint16_t.patch::https://github.com/ArduPilot/ardupilot/pull/23803.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 65e3e9065fa8..b7398e398d20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=ardupilot-copter-sitl
-pkgver=4.2.2
+pkgver=4.3.6
pkgdesc="Advanced, Fully-Featured, and Reliable Autopilot Software (Copter,
SITL)"
url='https://ardupilot.org'
@@ -30,7 +30,6 @@ sitl_depends=(
csfml
sfml
python-yaml
- python-argparse
python-wxpython
)
px4_depends=()
@@ -78,7 +77,7 @@ source=("${pkgname}-${pkgver}::git+https://github.com/ArduPilot/ardupilot.git#ta
"${pkgname}-pydronecan::git+https://github.com/DroneCAN/pydronecan.git"
"${pkgname}-dronecan_dsdlc::git+https://github.com/DroneCAN/dronecan_dsdlc.git"
"${pkgname}-libcanard::git+https://github.com/DroneCAN/libcanard.git"
- "uninitialized.patch::https://patch-diff.githubusercontent.com/raw/ArduPilot/ardupilot/pull/21183.patch"
+ "uint16_t.patch::https://github.com/ArduPilot/ardupilot/pull/23803.patch"
)
sha256sums=('SKIP'
'SKIP'
@@ -114,9 +113,9 @@ prepare() {
git config submodule."modules/DroneCAN/dronecan_dsdlc".url "${srcdir}/${pkgname}"-dronecan_dsdlc
git config submodule."modules/DroneCAN/libcanard".url "${srcdir}/${pkgname}"-libcanard
- git submodule update --init --recursive
+ git -c protocol.file.allow=always submodule update --init --recursive
- patch -Np1 -i "${srcdir}"/uninitialized.patch
+ patch -Np1 -i "${srcdir}"/uint16_t.patch
}
build() {