summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8552d2bbdfbe..16a690c67956 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,8 +4,10 @@ pkgbase = argos-uri-installer-git
pkgrel = 1
url = https://github.com/chabad360/argos-installer
arch = any
+ license = GPL3
makedepends = git
depends = gnome-shell-extension-argos-git
+ depends = desktop-file-utils
source = git+https://github.com/chabad360/argos-installer.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 671736d5a34d..148be731b0e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,9 @@ pkgrel=1
pkgdesc="Argos URI handler for bitbar://"
arch=('any')
url="https://github.com/chabad360/argos-installer"
-depends=('gnome-shell-extension-argos-git')
+license=('GPL3')
+depends=('gnome-shell-extension-argos-git'
+ 'desktop-file-utils')
makedepends=('git')
source=('git+https://github.com/chabad360/argos-installer.git')
md5sums=('SKIP')
@@ -17,6 +19,7 @@ prepare() {
package() {
cd "${srcdir}/argos-installer"
- install -Dm755 "add-argos" "${pkgdir}/usr/bin/add-argos"
- install -Dm644 "argos.desktop" "${pkgdir}/usr/share/applications/argos.desktop"
-} \ No newline at end of file
+ install -Dm755 "add-argos" "$pkgdir/usr/bin/add-argos"
+ install -Dm644 "argos.desktop" "$pkgdir/usr/share/applications/argos.desktop"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}