summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--aria2-fast.patch103
3 files changed, 52 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0406f8d07874..fa059158eafa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Dec 7 02:38:54 UTC 2015
+# Tue Feb 16 15:58:38 UTC 2016
pkgbase = aria2-fast
pkgdesc = Aria2 Download utility with little patch to maximize aria2 download speed
- pkgver = 1.19.3
+ pkgver = 1.20.0
pkgrel = 1
url = http://aria2.sourceforge.net/
arch = i686
@@ -19,10 +19,10 @@ pkgbase = aria2-fast
depends = libssh2
provides = aria2
conflicts = aria2
- source = https://github.com/tatsuhiro-t/aria2/releases/download/release-1.19.3/aria2-1.19.3.tar.xz
+ source = https://github.com/tatsuhiro-t/aria2/releases/download/release-1.20.0/aria2-1.20.0.tar.xz
source = aria2-fast.patch
- md5sums = b6363664e3cd510a092b0d812085724b
- md5sums = 5bfc37a15ce74bbdfbfa77fb871cc2e7
+ md5sums = 633b9f5c7a6d2a4198174cf895b4a038
+ md5sums = 28bcf743c3c08432f61f74913c0d413f
pkgname = aria2-fast
diff --git a/PKGBUILD b/PKGBUILD
index 6fbd6ce69b9e..20ed5e8754db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=aria2-fast
-pkgver=1.19.3
+pkgver=1.20.0
pkgrel=1
pkgdesc='Aria2 Download utility with little patch to maximize aria2 download speed'
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
@@ -45,5 +45,5 @@ package() {
${pkgdir}/usr/share/bash-completion/completions
rm -rf ${pkgdir}/usr/share/doc/aria2/bash_completion
}
-md5sums=('b6363664e3cd510a092b0d812085724b'
- '5bfc37a15ce74bbdfbfa77fb871cc2e7')
+md5sums=('633b9f5c7a6d2a4198174cf895b4a038'
+ '28bcf743c3c08432f61f74913c0d413f')
diff --git a/aria2-fast.patch b/aria2-fast.patch
index 89b0a3d220f5..3e74b02ec991 100644
--- a/aria2-fast.patch
+++ b/aria2-fast.patch
@@ -1,71 +1,56 @@
---- ../aria2-1.19.1.orig/src/OptionHandlerFactory.cc 2015-09-27 23:09:47.000000000 +0800
-+++ ./src/OptionHandlerFactory.cc 2015-09-29 23:24:46.406091311 +0800
-@@ -507,8 +507,8 @@ std::vector<OptionHandler*> OptionHandle
- OptionHandler* op(new NumberOptionHandler
- (PREF_MAX_CONNECTION_PER_SERVER,
- TEXT_MAX_CONNECTION_PER_SERVER,
-- "1",
-- 1, 16,
-+ "128",
-+ 1, -1,
- 'x'));
+--- a/src/OptionHandlerFactory.cc
++++ b/src/OptionHandlerFactory.cc
+@@ -419,7 +419,7 @@ std::vector<OptionHandler*> OptionHandlerFactory::createOptionHandlers()
+ {
+ OptionHandler* op(new NumberOptionHandler(PREF_MAX_CONNECTION_PER_SERVER,
+ TEXT_MAX_CONNECTION_PER_SERVER,
+- "1", 1, 16, 'x'));
++ "128", 1, -1, 'x'));
op->addTag(TAG_BASIC);
op->addTag(TAG_FTP);
-@@ -573,8 +573,8 @@ std::vector<OptionHandler*> OptionHandle
- OptionHandler* op(new UnitNumberOptionHandler
- (PREF_MIN_SPLIT_SIZE,
- TEXT_MIN_SPLIT_SIZE,
-- "20M",
-- 1_m, 1_g,
-+ "16K",
-+ 1_k, 1_g,
- 'k'));
+ op->addTag(TAG_HTTP);
+@@ -480,7 +480,7 @@ std::vector<OptionHandler*> OptionHandlerFactory::createOptionHandlers()
+ }
+ {
+ OptionHandler* op(new UnitNumberOptionHandler(
+- PREF_MIN_SPLIT_SIZE, TEXT_MIN_SPLIT_SIZE, "20M", 1_m, 1_g, 'k'));
++ PREF_MIN_SPLIT_SIZE, TEXT_MIN_SPLIT_SIZE, "4K", 1_k, 1_g, 'k'));
op->addTag(TAG_BASIC);
op->addTag(TAG_FTP);
-@@ -976,7 +976,7 @@ std::vector<OptionHandler*> OptionHandle
- OptionHandler* op(new NumberOptionHandler
- (PREF_CONNECT_TIMEOUT,
- TEXT_CONNECT_TIMEOUT,
-- "60",
-+ "30",
- 1, 600));
- op->addTag(TAG_FTP);
op->addTag(TAG_HTTP);
-@@ -1027,7 +1027,7 @@ std::vector<OptionHandler*> OptionHandle
- OptionHandler* op(new NumberOptionHandler
- (PREF_MAX_TRIES,
- TEXT_MAX_TRIES,
-- "5",
-+ "0",
- 0, -1,
- 'm'));
+@@ -791,7 +791,7 @@ std::vector<OptionHandler*> OptionHandlerFactory::createOptionHandlers()
+ }
+ {
+ OptionHandler* op(new NumberOptionHandler(
+- PREF_CONNECT_TIMEOUT, TEXT_CONNECT_TIMEOUT, "60", 1, 600));
++ PREF_CONNECT_TIMEOUT, TEXT_CONNECT_TIMEOUT, "30", 1, 600));
op->addTag(TAG_FTP);
-@@ -1071,8 +1071,8 @@ std::vector<OptionHandler*> OptionHandle
- OptionHandler* op(new UnitNumberOptionHandler
- (PREF_PIECE_LENGTH,
- TEXT_PIECE_LENGTH,
-- "1M",
-- 1_m, 1_g));
-+ "16K",
-+ 1_k, 1_g));
+ op->addTag(TAG_HTTP);
+ op->setInitialOption(true);
+@@ -862,7 +862,7 @@ std::vector<OptionHandler*> OptionHandlerFactory::createOptionHandlers()
+ }
+ {
+ OptionHandler* op(new UnitNumberOptionHandler(
+- PREF_PIECE_LENGTH, TEXT_PIECE_LENGTH, "1M", 1_m, 1_g));
++ PREF_PIECE_LENGTH, TEXT_PIECE_LENGTH, "4k", 1_k, 1_g));
op->addTag(TAG_ADVANCED);
op->addTag(TAG_FTP);
op->addTag(TAG_HTTP);
-@@ -1098,7 +1098,7 @@ std::vector<OptionHandler*> OptionHandle
- OptionHandler* op(new NumberOptionHandler
- (PREF_RETRY_WAIT,
- TEXT_RETRY_WAIT,
-- "0",
-+ "4",
- 0, 600));
+@@ -883,7 +883,7 @@ std::vector<OptionHandler*> OptionHandlerFactory::createOptionHandlers()
+ }
+ {
+ OptionHandler* op(
+- new NumberOptionHandler(PREF_RETRY_WAIT, TEXT_RETRY_WAIT, "0", 0, 600));
++ new NumberOptionHandler(PREF_RETRY_WAIT, TEXT_RETRY_WAIT, "2", 0, 600));
op->addTag(TAG_FTP);
op->addTag(TAG_HTTP);
-@@ -1155,7 +1155,7 @@ std::vector<OptionHandler*> OptionHandle
- OptionHandler* op(new NumberOptionHandler
- (PREF_SPLIT,
- TEXT_SPLIT,
-- "5",
-+ "8",
- 1, -1,
- 's'));
+ op->setInitialOption(true);
+@@ -928,7 +928,7 @@ std::vector<OptionHandler*> OptionHandlerFactory::createOptionHandlers()
+ }
+ {
+ OptionHandler* op(
+- new NumberOptionHandler(PREF_SPLIT, TEXT_SPLIT, "5", 1, -1, 's'));
++ new NumberOptionHandler(PREF_SPLIT, TEXT_SPLIT, "8", 1, -1, 's'));
op->addTag(TAG_BASIC);
+ op->addTag(TAG_FTP);
+ op->addTag(TAG_HTTP);