summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD14
-rw-r--r--ariang-post-install.hook2
4 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5aa33a614c4b..a3a39e9a243c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = ariang-git
pkgdesc = a modern web frontend making aria2 easier to use.
- pkgver = 1.3.3.r0.g17e7714
+ pkgver = 1.3.7.r2.g5c47d61
pkgrel = 1
url = https://github.com/mayswind/AriaNg
arch = any
license = MIT
makedepends = git
- makedepends = nodejs
+ makedepends = npm
makedepends = gulp
makedepends = openssh
optdepends = aria2: if you use ariang locally
@@ -19,6 +19,6 @@ pkgbase = ariang-git
source = git+https://github.com/mayswind/AriaNg.git
source = ariang-post-install.hook
sha256sums = SKIP
- sha256sums = ceb1903822653f6ef5c10b2ec19287a4d7fc6afa3854784015b53b61b12fd62f
+ sha256sums = 52424300b6227eb28641f77bbd6ff67f4a3114e515c66dac650382f842f5c07e
pkgname = ariang-git
diff --git a/.gitignore b/.gitignore
index 3d4ef2df1286..c6a216012da8 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,5 @@
pkg
src
*.pkg.tar.*
+*.log
+AriaNg
diff --git a/PKGBUILD b/PKGBUILD
index 554bd8ffd87a..37f44b5bd5f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Zhang Hua <zhanghua.00 at qq dot com>
pkgname=ariang-git
-pkgver=1.3.3.r0.g17e7714
+pkgver=1.3.7.r2.g5c47d61
pkgrel=1
pkgdesc="a modern web frontend making aria2 easier to use."
arch=("any")
url="https://github.com/mayswind/AriaNg"
license=("MIT")
-makedepends=("git" "nodejs" "gulp" "openssh")
+makedepends=("git" "npm" "gulp" "openssh")
optdepends=(
"aria2: if you use ariang locally"
"apache: for web server"
@@ -20,7 +20,7 @@ source=(
"git+${url}.git"
"ariang-post-install.hook")
sha256sums=('SKIP'
- 'ceb1903822653f6ef5c10b2ec19287a4d7fc6afa3854784015b53b61b12fd62f')
+ '52424300b6227eb28641f77bbd6ff67f4a3114e515c66dac650382f842f5c07e')
pkgver(){
cd "${srcdir}/AriaNg"
@@ -28,13 +28,13 @@ pkgver(){
}
build(){
cd "${srcdir}/AriaNg"
- node /usr/lib/node_modules/corepack/dist/pnpm.js install
- gulp clean build
+ npm install
+ npm run build
}
package(){
cd "${srcdir}/AriaNg"
- mkdir -p "${pkgdir}/usr/share"
- cp -av dist "${pkgdir}/usr/share/ariang"
+ mkdir -p "${pkgdir}/usr/share/webapps"
+ cp -av dist "${pkgdir}/usr/share/webapps/ariang"
install -Dm644 "${srcdir}/ariang-post-install.hook" \
"${pkgdir}/usr/share/libalpm/hooks/ariang.hook"
}
diff --git a/ariang-post-install.hook b/ariang-post-install.hook
index af6c670385a9..e6baa9ac16b6 100644
--- a/ariang-post-install.hook
+++ b/ariang-post-install.hook
@@ -7,4 +7,4 @@ Target = ariang-git
[Action]
Description = Notifying user about manual operations...
When = PostTransaction
-Exec = /usr/bin/echo "Please copy /usr/share/ariang to /srv/http and use a webserver on /srv/http/ariang."
+Exec = /usr/bin/echo "Please copy /usr/share/webapps/ariang to /srv/http and use a webserver on /srv/http/ariang."