summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77f05159ec5c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = aribb25
+ pkgdesc = Basic implementation of the ARIB STD-B25 public standard
+ pkgver = 0.2.7
+ pkgrel = 1
+ url = https://code.videolan.org/videolan/aribb25
+ arch = x86_64
+ license = custom:ISC
+ makedepends = libtool
+ makedepends = autoconf
+ makedepends = pkg-config
+ makedepends = automake
+ depends = pcsclite
+ source = https://code.videolan.org/videolan/aribb25/-/archive/0.2.7/aribb25-0.2.7.tar.gz
+ sha256sums = 3d057fe0c5cd04c78364736c352c4f8c650d48e57a5e5effdb8e3fef9faab4e6
+
+pkgname = aribb25
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..375009a4f9ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Frederick Zhang <frederick888@tsundere.moe>
+pkgname=aribb25
+pkgver=0.2.7
+pkgrel=1
+pkgdesc="Basic implementation of the ARIB STD-B25 public standard"
+arch=('x86_64')
+url="https://code.videolan.org/videolan/aribb25"
+license=('custom:ISC')
+source=("https://code.videolan.org/videolan/aribb25/-/archive/$pkgver/aribb25-$pkgver.tar.gz")
+sha256sums=('3d057fe0c5cd04c78364736c352c4f8c650d48e57a5e5effdb8e3fef9faab4e6')
+depends=('pcsclite')
+makedepends=('libtool' 'autoconf' 'pkg-config' 'automake')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./bootstrap
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 LICENCE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}