summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--02-cleaner.patch25
-rw-r--r--PKGBUILD4
3 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 887d69484d7f..37cf978fecf0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = arkenfox-user.js-git
pkgdesc = Firefox privacy, security and anti-tracking: a comprehensive user.js template for configuration and hardening.
- pkgver = 117.0.r0.g1e6e211
+ pkgver = 118.0.r0.g3fdcb28
pkgrel = 1
url = https://github.com/arkenfox/user.js
arch = any
@@ -14,6 +14,6 @@ pkgbase = arkenfox-user.js-git
source = 02-cleaner.patch
sha256sums = SKIP
sha256sums = aec6852c49f697a9f00229a028df73fdc98a3841f066d56280b5f7992d796e78
- sha256sums = 6cb83edb60a8affdab79b361c3ad52f1f70d3c4d123e8be0b409441e6a752691
+ sha256sums = 56202bde446ec07735377a8e3e465460b19dc5640290ec8c88d8dea9fe807c8e
pkgname = arkenfox-user.js-git
diff --git a/02-cleaner.patch b/02-cleaner.patch
index d0dfc584da8a..371c46f4fd01 100644
--- a/02-cleaner.patch
+++ b/02-cleaner.patch
@@ -1,6 +1,6 @@
--- prefsCleaner.sh
+++ prefsCleaner.sh
-@@ -22,10 +16,0 @@
+@@ -11,10 +10,0 @@
-readonly CURRDIR=$(pwd)
-
-## get the full path of this script (readlink for Linux, greadlink for Mac with coreutils installed)
@@ -11,7 +11,7 @@
-
-
-AUTOUPDATE=true
-@@ -34,11 +18,0 @@
+@@ -23,11 +12,0 @@
-## download method priority: curl -> wget
-DOWNLOAD_METHOD=''
-if command -v curl >/dev/null; then
@@ -23,10 +23,10 @@
- echo -e "No curl or wget detected.\nAutomatic self-update disabled!"
-fi
-
-@@ -46,2 +19,0 @@
+@@ -35,2 +13,0 @@
- ## change directory back to the original working directory
- cd "${CURRDIR}"
-@@ -57,7 +29 @@
+@@ -46,7 +23 @@
- -d Don't auto-update prefsCleaner.sh"
-}
-
@@ -35,7 +35,7 @@
-
- $DOWNLOAD_METHOD "${tf}" "$1" &>/dev/null && echo "$tf" || echo '' # return the temp-filename or empty string on error
+"
-@@ -75,18 +40,0 @@
+@@ -64,18 +34,0 @@
-## returns the version number of a prefsCleaner.sh file
-get_prefsCleaner_version() {
- echo "$(sed -n '5 s/.*[[:blank:]]\([[:digit:]]*\.[[:digit:]]*\)/\1/p' "$1")"
@@ -54,16 +54,23 @@
- exit 0
-}
-
-@@ -132 +80 @@
+@@ -121 +74 @@
-while getopts "sd" opt; do
+while getopts "s" opt; do
-@@ -137,3 +84,0 @@
+@@ -126,3 +78,0 @@
- d)
- AUTOUPDATE=false
- ;;
-@@ -142,5 +86,0 @@
--
+@@ -132,3 +81,0 @@
-## change directory to the Firefox profile directory
-cd "$(dirname "${SCRIPT_FILE}")"
-
+@@ -138,5 +84,0 @@
+-elif [ -n "$(find ./ -user 0 -o -group 0)" ]; then
+- printf 'It looks like this script was previously run with elevated privileges,
+-you will need to change ownership of the following files to your user:\n'
+- find . -user 0 -o -group 0
+- fQuit 1
+@@ -144,2 +85,0 @@
+-
-[ "$AUTOUPDATE" = true ] && update_prefsCleaner "$@"
diff --git a/PKGBUILD b/PKGBUILD
index f0d800b31c68..eb974823ad57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@ _name=arkenfox
_repo=user.js
_base=${_name}-${_repo}
pkgname=${_base}-git
-pkgver=117.0.r0.g1e6e211
+pkgver=118.0.r0.g3fdcb28
pkgrel=1
pkgdesc="Firefox privacy, security and anti-tracking: a comprehensive user.js template for configuration and hardening."
arch=('any')
@@ -22,7 +22,7 @@ source=(
sha256sums=(
'SKIP'
'aec6852c49f697a9f00229a028df73fdc98a3841f066d56280b5f7992d796e78'
- '6cb83edb60a8affdab79b361c3ad52f1f70d3c4d123e8be0b409441e6a752691'
+ '56202bde446ec07735377a8e3e465460b19dc5640290ec8c88d8dea9fe807c8e'
)
pkgver() {