summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
-rw-r--r--Unlink-the-response-file.patch54
4 files changed, 25 insertions, 94 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d11e483d42e4..6fb8c13e5c6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Feb 29 16:52:55 UTC 2016
+# Mon May 16 22:22:22 UTC 2016
pkgbase = arm-linux-gnueabihf-gcc-stage2
pkgdesc = The GNU Compiler Collection. Stage 2 for toolchain building (arm-linux-gnueabihf)
- pkgver = 5.3.0
- pkgrel = 5
+ pkgver = 6.1.1
+ pkgrel = 1
url = http://gcc.gnu.org
arch = i686
arch = x86_64
@@ -11,22 +11,20 @@ pkgbase = arm-linux-gnueabihf-gcc-stage2
license = LGPL
license = FDL
license = custom
- depends = arm-linux-gnueabihf-binutils>=2.26
- depends = arm-linux-gnueabihf-glibc-headers>=2.23
+ depends = arm-linux-gnueabihf-binutils>=2.26-4
+ depends = arm-linux-gnueabihf-glibc-headers>=2.23-4
depends = libmpc
depends = zlib
- provides = arm-linux-gnueabihf-gcc-stage1=5.3.0
+ provides = arm-linux-gnueabihf-gcc-stage1=6.1.1
conflicts = arm-linux-gnueabihf-gcc-stage1
replaces = arm-linux-gnueabihf-gcc-stage1
options = !emptydirs
options = !distcc
options = !strip
- source = ftp://gcc.gnu.org/pub/gcc/snapshots/5-20160209/gcc-5-20160209.tar.bz2
- source = http://isl.gforge.inria.fr/isl-0.15.tar.bz2
- source = Unlink-the-response-file.patch
- md5sums = 499161c65b639aa5c12a14944582b7ec
- md5sums = 8428efbbc6f6e2810ce5c1ba73ecf98c
- md5sums = 1f4d4ef71004261376d26d5ba6a84499
+ source = https://github.com/gcc-mirror/gcc/archive/80f78834.tar.gz
+ source = http://isl.gforge.inria.fr/isl-0.16.1.tar.bz2
+ md5sums = 405eea1379f597d9876e33636c9cb6c7
+ md5sums = ac1f25a0677912952718a51f5bc20f32
pkgname = arm-linux-gnueabihf-gcc-stage2
diff --git a/.gitignore b/.gitignore
index fc606369d37f..7eb1956e4830 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,8 +1,8 @@
*.pkg.*
src/
pkg/
-gcc-*.tar.bz2
-isl-*.tar.bz2
+*.tar.gz
+*.tar.bz2
*.sig
*.sign
*.part
diff --git a/PKGBUILD b/PKGBUILD
index 28caca3dd768..3089f23b11b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,36 +6,28 @@
_target="arm-linux-gnueabihf"
pkgname=${_target}-gcc-stage2
-pkgver=5.3.0
-_pkgver=5
-_islver=0.15
-pkgrel=5
-_snapshot=5-20160209
+pkgver=6.1.1
+_pkgver=6
+_islver=0.16.1
+pkgrel=1
+_commit=80f78834
pkgdesc="The GNU Compiler Collection. Stage 2 for toolchain building (${_target})"
arch=('i686' 'x86_64')
license=('GPL' 'LGPL' 'FDL' 'custom')
url="http://gcc.gnu.org"
-depends=("${_target}-binutils>=2.26" "${_target}-glibc-headers>=2.23" 'libmpc' 'zlib')
+depends=("${_target}-binutils>=2.26-4" "${_target}-glibc-headers>=2.23-4" 'libmpc' 'zlib')
options=('!emptydirs' '!distcc' '!strip')
conflicts=("${_target}-gcc-stage1")
replaces=("${_target}-gcc-stage1")
provides=("${_target}-gcc-stage1=${pkgver}")
-source=(#ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
- ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
- http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2
- Unlink-the-response-file.patch)
-md5sums=('499161c65b639aa5c12a14944582b7ec'
- '8428efbbc6f6e2810ce5c1ba73ecf98c'
- '1f4d4ef71004261376d26d5ba6a84499')
-
-if [ -n "${_snapshot}" ]; then
- _basedir=gcc-${_snapshot}
-else
- _basedir=gcc-${pkgver}
-fi
+source=(https://github.com/gcc-mirror/gcc/archive/${_commit}.tar.gz
+ http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2)
+md5sums=('405eea1379f597d9876e33636c9cb6c7'
+ 'ac1f25a0677912952718a51f5bc20f32')
prepare() {
- cd ${srcdir}/${_basedir}
+ mv gcc-${_commit}* gcc
+ cd ${srcdir}/gcc
# link isl for in-tree build
ln -s ../isl-${_islver} isl
@@ -43,14 +35,9 @@ prepare() {
# Do not run fixincludes
sed -i 's@\./fixinc\.sh@-c true@' gcc/Makefile.in
- echo ${pkgver} > gcc/BASE-VER
-
# hack! - some configure tests for header files using "$CPP $CPPFLAGS"
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
- # https://bugs.archlinux.org/task/47874 - commit f591a95d
- patch -p1 -i $srcdir/Unlink-the-response-file.patch
-
mkdir ${srcdir}/gcc-build
}
@@ -62,7 +49,7 @@ build() {
CFLAGS=${CFLAGS/-pipe/}
CXXFLAGS=${CXXFLAGS/-pipe/}
- ${srcdir}/${_basedir}/configure --prefix=/usr \
+ ${srcdir}/gcc/configure --prefix=/usr \
--program-prefix=${_target}- \
--with-local-prefix=/usr/${_target} \
--with-sysroot=/usr/${_target} \
diff --git a/Unlink-the-response-file.patch b/Unlink-the-response-file.patch
deleted file mode 100644
index 55c95a7972c9..000000000000
--- a/Unlink-the-response-file.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From f591a95d1532ac7791c146a8e55ba3a32b3e476f Mon Sep 17 00:00:00 2001
-From: ebotcazou <ebotcazou@138bc75d-0d04-0410-961f-82ee72b054a4>
-Date: Tue, 23 Jun 2015 20:48:07 +0000
-Subject: [PATCH] * collect-utils.c (collect_wait): Unlink the
- response file here instead of... (do_wait): ...here.
- (utils_cleanup): ...and here.
-
-git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@224858 138bc75d-0d04-0410-961f-82ee72b054a4
----
- gcc/ChangeLog | 7 +++++++
- gcc/collect-utils.c | 14 ++++++--------
- 2 files changed, 13 insertions(+), 8 deletions(-)
-
-diff --git a/gcc/collect-utils.c b/gcc/collect-utils.c
-index 6bbe9eb..517a075 100644
---- a/gcc/collect-utils.c
-+++ b/gcc/collect-utils.c
-@@ -68,6 +68,12 @@ collect_wait (const char *prog, struct pex_obj *pex)
- fatal_error (input_location, "can't get program status: %m");
- pex_free (pex);
-
-+ if (response_file && !save_temps)
-+ {
-+ unlink (response_file);
-+ response_file = NULL;
-+ }
-+
- if (status)
- {
- if (WIFSIGNALED (status))
-@@ -90,12 +96,6 @@ do_wait (const char *prog, struct pex_obj *pex)
- int ret = collect_wait (prog, pex);
- if (ret != 0)
- fatal_error (input_location, "%s returned %d exit status", prog, ret);
--
-- if (response_file && !save_temps)
-- {
-- unlink (response_file);
-- response_file = NULL;
-- }
- }
-
-
-@@ -224,7 +224,5 @@ utils_cleanup (bool from_signal)
- calls to maybe_unlink fails. */
- cleanup_done = true;
-
-- if (response_file)
-- maybe_unlink (response_file);
- tool_cleanup (from_signal);
- }
---
-2.7.1
-