summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 14 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9715939340a4..324bd88cdc07 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Fri Dec 11 22:21:23 UTC 2015
pkgbase = arm-linux-gnueabihf-gcc-stage2
pkgdesc = The GNU Compiler Collection. Stage 2 for toolchain building (arm-linux-gnueabihf)
- pkgver = 5.2.0
+ pkgver = 5.3.0
pkgrel = 2
url = http://gcc.gnu.org
arch = i686
@@ -19,12 +21,10 @@ pkgbase = arm-linux-gnueabihf-gcc-stage2
options = !emptydirs
options = !distcc
options = !strip
- source = ftp://gcc.gnu.org/pub/gcc/releases/gcc-5.2.0/gcc-5.2.0.tar.bz2
- source = http://isl.gforge.inria.fr/isl-0.14.1.tar.bz2
- source = pr66035.patch
- md5sums = a51bcfeb3da7dd4c623e27207ed43467
- md5sums = 118d1a379abf7606a3334c98a8411c79
- md5sums = 5b980076cd5fcbc3aff6014f306282dd
+ source = ftp://gcc.gnu.org/pub/gcc/releases/gcc-5.3.0/gcc-5.3.0.tar.bz2
+ source = http://isl.gforge.inria.fr/isl-0.15.tar.bz2
+ md5sums = c9616fd448f980259c31de613e575719
+ md5sums = 8428efbbc6f6e2810ce5c1ba73ecf98c
pkgname = arm-linux-gnueabihf-gcc-stage2
diff --git a/PKGBUILD b/PKGBUILD
index 2c595d007de8..869a929ecb30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,10 +6,11 @@
_target="arm-linux-gnueabihf"
pkgname=${_target}-gcc-stage2
-pkgver=5.2.0
+pkgver=5.3.0
_pkgver=5
-_islver=0.14.1
+_islver=0.15
pkgrel=2
+#_snapshot=5-20150623
pkgdesc="The GNU Compiler Collection. Stage 2 for toolchain building (${_target})"
arch=('i686' 'x86_64')
license=('GPL' 'LGPL' 'FDL' 'custom')
@@ -21,11 +22,9 @@ replaces=("${_target}-gcc-stage1")
provides=("${_target}-gcc-stage1")
source=(ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
#ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
- http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2
- pr66035.patch)
-md5sums=('a51bcfeb3da7dd4c623e27207ed43467'
- '118d1a379abf7606a3334c98a8411c79'
- '5b980076cd5fcbc3aff6014f306282dd')
+ http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2)
+md5sums=('c9616fd448f980259c31de613e575719'
+ '8428efbbc6f6e2810ce5c1ba73ecf98c')
if [ -n "${_snapshot}" ]; then
_basedir=gcc-${_snapshot}
@@ -47,9 +46,6 @@ prepare() {
# hack! - some configure tests for header files using "$CPP $CPPFLAGS"
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
- # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=66035
- patch -p1 -i ${srcdir}/pr66035.patch
-
mkdir ${srcdir}/gcc-build
}
@@ -81,8 +77,7 @@ build() {
--disable-lto --disable-plugin --enable-install-libiberty \
--with-linker-hash-style=gnu --enable-gnu-indirect-function \
--disable-multilib --disable-werror \
- --enable-checking=release \
- --with-default-libstdcxx-abi=gcc4-compatible
+ --enable-checking=release
make all-gcc all-target-libgcc
}