summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rwxr-xr-xPKGBUILD20
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eac8dd04737c..6480555029b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = arm-none-eabi-gcc60-linaro
pkgdesc = The GNU Compiler Collection - cross compiler for ARM EABI (bare-metal) target.
- pkgver = 6.2_2016.09
+ pkgver = 6.2_2016.10
pkgrel = 1
url = https://releases.linaro.org/
arch = i686
@@ -13,7 +13,7 @@ pkgbase = arm-none-eabi-gcc60-linaro
depends = arm-none-eabi-binutils>=2.26-1
depends = gmp
depends = cloog-git
- depends = arm-none-eabi-newlib
+ depends = arm-none-eabi-newlib-linaro-git
depends = mpfr
depends = libmpc
provides = arm-none-eabi-gcc
@@ -25,11 +25,11 @@ pkgbase = arm-none-eabi-gcc60-linaro
options = !strip
options = zipman
options = docs
- source = http://snapshots.linaro.org/components/toolchain/gcc-linaro/6.2-2016.09/gcc-linaro-snapshot-6.2-2016.09.tar.xz
+ source = http://snapshots.linaro.org/components/toolchain/gcc-linaro/6.2-2016.10/gcc-linaro-snapshot-6.2-2016.10.tar.xz
source = 0200-gcc-no-exceptions.patch
source = 0300-gcc-multilib2.patch
source = 1039-libcc1-fix-libcc1-s-install-path-and-rpath.patch
- sha256sums = 7d3e0508248ac491f0d9fb0772ae06862d4cc88405b06d19ceed8a4fc963b688
+ sha256sums = d0082159bd5bb609e07c24a414666e1c2820d9b8ce6e39462f5927d6104fd3d8
sha256sums = 76eab14830216c774291d2ac35d4b4690f3273aa8c630a2c1546f02538847d8a
sha256sums = c9b6bc1dd53f9b4b80f5fdacdef94c9fce0e516c16fb78063107b66ba2e9fdd1
sha256sums = fa08269d6a748631b07b55a5fe00fa518b2f6e04356a3d6634c60f3c3ece3b07
diff --git a/PKGBUILD b/PKGBUILD
index a6b36790eb07..c4cd33b547a6 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,20 @@
pkgname=arm-none-eabi-gcc60-linaro
_relver=snapshot-6.2
-_relshortdate=16.09
+_relshortdate=16.10
_reldate=20${_relshortdate}
_relverdate=${_relver}-${_reldate}
# This is how I want to define the pkgver, but the AUR doesn't understand it, because multiple _ characters are not allowed
#pkgver=${_relver}_${_reldate//-/_}
-pkgver=6.2_2016.09
-_pkgver=6.2-2016.09
+pkgver=6.2_2016.10
+_pkgver=6.2-2016.10
pkgrel=1
pkgdesc="The GNU Compiler Collection - cross compiler for ARM EABI (bare-metal) target."
arch=(i686 x86_64)
url="https://releases.linaro.org/"
license=('GPL' 'LGPL')
groups=('arm-none-eabi-toolchain')
-depends=('arm-none-eabi-binutils>=2.26-1' 'gmp' 'cloog-git' 'arm-none-eabi-newlib' 'mpfr' 'libmpc')
+depends=('arm-none-eabi-binutils>=2.26-1' 'gmp' 'cloog-git' 'arm-none-eabi-newlib-linaro-git' 'mpfr' 'libmpc')
makedepends=('flex' 'bison')
provides=('arm-none-eabi-gcc')
conflicts=('arm-none-eabi-gcc' 'cross-arm-none-eabi-gcc')
@@ -37,8 +37,8 @@ cd ${srcdir}/${_basedir}
mkdir build
cd build
- export CFLAGS="-O2"
- export CXXFLAGS="-O2"
+ export CFLAGS="-O3"
+ export CXXFLAGS="-O3"
unset CPPFLAGS
../configure --with-pkgversion="Arch User Repository" \
--with-bugurl="https://aur.archlinux.org/packages/arm-none-eabi-gcc-linaro" \
@@ -76,7 +76,7 @@ package() {
# vim: set ts=2 sw=2 ft=sh et:
-sha256sums=('7d3e0508248ac491f0d9fb0772ae06862d4cc88405b06d19ceed8a4fc963b688'
- '76eab14830216c774291d2ac35d4b4690f3273aa8c630a2c1546f02538847d8a'
- 'c9b6bc1dd53f9b4b80f5fdacdef94c9fce0e516c16fb78063107b66ba2e9fdd1'
- 'fa08269d6a748631b07b55a5fe00fa518b2f6e04356a3d6634c60f3c3ece3b07')
+sha256sums=('d0082159bd5bb609e07c24a414666e1c2820d9b8ce6e39462f5927d6104fd3d8'
+ '76eab14830216c774291d2ac35d4b4690f3273aa8c630a2c1546f02538847d8a'
+ 'c9b6bc1dd53f9b4b80f5fdacdef94c9fce0e516c16fb78063107b66ba2e9fdd1'
+ 'fa08269d6a748631b07b55a5fe00fa518b2f6e04356a3d6634c60f3c3ece3b07')