summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD5
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75596e3bbf69..5a05a8652bc7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = arm-none-eabi-gdb-linaro
pkgdesc = Linaro GDB is a branch of FSF GDB that contains ARM focused features and patches.
pkgver = 7.8_2014.09
- pkgrel = 1
+ pkgrel = 2
url = https://releases.linaro.org/
arch = i686
arch = x86_64
@@ -10,14 +10,15 @@ pkgbase = arm-none-eabi-gdb-linaro
makedepends = texinfo
depends = ncurses
depends = expat
- depends = python2
+ depends = python36
+ depends = guile2.0
optdepends = openocd: for debugging JTAG targets
provides = arm-none-eabi-gdb
conflicts = cross-arm-none-eabi-gdb
conflicts = arm-none-eabi-gdb
options = !libtool
options = !emptydirs
- source = https://releases.linaro.org/14.09/components/toolchain/gdb-linaro/gdb-linaro-7.8-2014.09.tar.xz
+ source = https://releases.linaro.org/archive/14.09/components/toolchain/gdb-linaro/gdb-linaro-7.8-2014.09.tar.xz
sha256sums = fbbe96b8d0debf7c2d8c9a4a6c7ca0ba87d536e43289f81c4af56f95e5f7b5ea
pkgname = arm-none-eabi-gdb-linaro
diff --git a/PKGBUILD b/PKGBUILD
index 7c18cc9cf8e0..2c00e47cb09c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,13 @@ _relverdate=${_relver}-${_reldate}
# This is how I want to define the pkgver, but the AUR doesn't understand it
#pkgver=${_relver}_${_reldate//-/_}
pkgver=7.8_2014.09
-pkgrel=1
+pkgrel=2
pkgdesc="Linaro GDB is a branch of FSF GDB that contains ARM focused features and patches."
arch=(i686 x86_64)
url="https://releases.linaro.org/"
license=('GPL3')
groups=('arm-none-eabi-toolchain')
-depends=('ncurses' 'expat' 'python2')
+depends=('ncurses' 'expat' 'python36' 'guile2.0')
makedepends=('texinfo')
optdepends=('openocd: for debugging JTAG targets')
provides=('arm-none-eabi-gdb')
@@ -36,6 +36,7 @@ build() {
--enable-interwork \
--with-system-readline \
--with-guile=guile-2.0 \
+ --with-python=python3.6 \
--disable-nls
make
}