summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e806881ab1f..d7b10cb57ac0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,7 +8,9 @@ pkgbase = armcord-bin
license = MIT
provides = armcord
options = !strip
- sha256sums = 022c6944ee1111e657b8d9899a2c7fd92f6dc42a34e6f08e4aa54a0f844a7c6f
- source_x86_64 = https://github.com/smartfrigde/armcord/releases/download/v2.5.0/ArmCord-2.5.0.tar.gz
+ source_x86_64 = armcord.tar.gz::https://github.com/smartfrigde/armcord/releases/download/v2.5.0/ArmCord-2.5.0.tar.gz
+ sha256sums_x86_64 = 62e71be81f56eaf99e59b24dc07878fa1579dc0caf71e1ea57091bbf02dfd547
+ source_aarch64 = armcord.tar.gz::https://github.com/ArmCord/ArmCord/releases/download/v2.5.0/ArmCord-2.5.0-arm64.tar.gz
+ sha256sums_aarch64 = 6c9e02d91c264fe24b1eb2c26e7cd52d9a4fb95eae78f675608161db7ae56195
pkgname = armcord-bin
diff --git a/PKGBUILD b/PKGBUILD
index e1538207845e..064363801da8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,12 +10,20 @@ url="https://github.com/smartfrigde/armcord"
license=('MIT')
options=(!strip)
-source_x86_64=("https://github.com/smartfrigde/armcord/releases/download/v2.5.0/ArmCord-2.5.0.tar.gz")
-sha256sums=("022c6944ee1111e657b8d9899a2c7fd92f6dc42a34e6f08e4aa54a0f844a7c6f")
+source_x86_64=("armcord.tar.gz::https://github.com/smartfrigde/armcord/releases/download/v2.5.0/ArmCord-2.5.0.tar.gz")
+sha256sums_x86_64=("62e71be81f56eaf99e59b24dc07878fa1579dc0caf71e1ea57091bbf02dfd547")
+source_aarch64=("armcord.tar.gz::https://github.com/ArmCord/ArmCord/releases/download/v2.5.0/ArmCord-2.5.0-arm64.tar.gz")
+sha256sums_aarch64=("6c9e02d91c264fe24b1eb2c26e7cd52d9a4fb95eae78f675608161db7ae56195")
package() {
+ echo "CPU arch: $CARCH"
# enter directory
- cd "$srcdir/ArmCord-2.5.0"
+ if [ $CARCH = "x86_64" ]; then
+ cd "$srcdir/ArmCord-2.5.0"
+ fi
+ if [ $CARCH = "aarch64" ]; then
+ cd "$srcdir/ArmCord-2.5.0-arm64"
+ fi
# move all files to the appropriate place
mkdir -p "$pkgdir/opt/armcord"