summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
-rw-r--r--armok-vision18
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88893804cc25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Mar 1 16:17:11 UTC 2016
+pkgbase = armok-vision
+ pkgdesc = A 3d realtime visualizer for Dwarf Fortress
+ pkgver = 0.7.2
+ pkgrel = 1
+ url = https://github.com/JapaMala/armok-vision
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = dfhack=0.40.24_r5-1
+ depends = dwarffortress=0.40.24-5
+ source = armok-vision-0.7.2.zip::https://github.com/JapaMala/armok-vision/releases/download/v0.7.2/Armok.Vision.0.7.2.Linux.zip
+ source = armok-vision
+ md5sums = c31d7bf9ce52546bcb380b67e061ecbc
+ md5sums = 76daf6967fcc4cc51e04ef14ab665200
+
+pkgname = armok-vision
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf8a6a9c20b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Chris Höppner <me@mkaito.com>
+pkgname=armok-vision
+pkgver=0.7.2
+pkgrel=1
+pkgdesc="A 3d realtime visualizer for Dwarf Fortress"
+arch=('i686' 'x86_64')
+url="https://github.com/JapaMala/armok-vision"
+license=('MIT')
+depends=('dfhack=0.40.24_r5-1' 'dwarffortress=0.40.24-5')
+source=("$pkgname-$pkgver.zip::https://github.com/JapaMala/armok-vision/releases/download/v0.7.2/Armok.Vision.0.7.2.Linux.zip"
+ "armok-vision")
+md5sums=('c31d7bf9ce52546bcb380b67e061ecbc'
+ '76daf6967fcc4cc51e04ef14ab665200')
+
+package() {
+ mkdir -p $pkgdir/opt/dwarffortress/armok-vision
+ cp -r "Armok Vision_Data" $pkgdir/opt/dwarffortress/armok-vision/
+ install -Dm755 "Armok Vision.x86" "$pkgdir/opt/dwarffortress/armok-vision/Armok Vision.x86"
+ install -Dm755 "Armok Vision.x86_64" "$pkgdir/opt/dwarffortress/armok-vision/Armok Vision.x86_64"
+ install -Dm755 armok-vision $pkgdir/usr/bin/armok-vision
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# sh-indentation: 2
+# End:
diff --git a/armok-vision b/armok-vision
new file mode 100644
index 000000000000..66bbf8a1b4a4
--- /dev/null
+++ b/armok-vision
@@ -0,0 +1,18 @@
+#!/usr/bin/sh
+
+cd "/opt/dwarffortress/armok-vision"
+arch=$(uname -m)
+if [ "$arch" = "i686" ]; then
+ exec "./Armok Vision.x86"
+elif [ "$arch" = "x86_64" ]; then
+ exec "./Armok Vision.x86_64"
+else
+ echo "Architecture $arch not recognized. Please notify the AUR package maintainer by posting a comment here:"
+ echo "https://aur.archlinux.org/packages/armok-vision/"
+fi
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# sh-indentation: 2
+# End: