summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD13
-rw-r--r--armorpaint.sh2
4 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be844be0be34..10597ed0afbe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = armorpaint-git
pkgdesc = ArmorPaint is a software for 3D PBR texture painting
- pkgver = 0.8.r1870.g4795f36
+ pkgver = 0.9.r2900.gef390132
pkgrel = 1
url = https://armorpaint.org/
arch = i686
@@ -25,9 +25,8 @@ pkgbase = armorpaint-git
source = armorpaint.desktop
source = armorpaint.png
md5sums = SKIP
- md5sums = 728cc52bfa9e7b16390459e7a80fad16
+ md5sums = 74001d6c572fc79c96d0bee24427f7ba
md5sums = dd5d97aadd39966ff7d9dda68b5ae29a
md5sums = 67cf4a0cb08c66c4a68c677885e8ac99
pkgname = armorpaint-git
-
diff --git a/.gitignore b/.gitignore
index 16bc8759b325..d3f12ea7d327 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@ armorpaint
pkg
src
*.xz
+*.zst
diff --git a/PKGBUILD b/PKGBUILD
index 993df4c37be8..06f2d5ec1735 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=('armorpaint-git')
_pkgname='armorpaint'
-pkgver=0.8.r1870.g4795f36
+pkgver=0.9.r2900.gef390132
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="ArmorPaint is a software for 3D PBR texture painting"
@@ -18,7 +18,7 @@ source=("git+https://github.com/armory3d/armorpaint"
"armorpaint.desktop"
"armorpaint.png")
md5sums=(SKIP
- "728cc52bfa9e7b16390459e7a80fad16"
+ "74001d6c572fc79c96d0bee24427f7ba"
"dd5d97aadd39966ff7d9dda68b5ae29a"
"67cf4a0cb08c66c4a68c677885e8ac99")
@@ -35,11 +35,8 @@ prepare() {
build() {
cd "$srcdir/${_pkgname}"
- node armorcore/make -g opengl
- cd armorcore
- node Kinc/make -g opengl --compiler clang --compile
- cd Deployment
- strip Krom
+ armorcore/Kinc/make --from armorcore -g opengl --compiler clang --compile
+ strip armorcore/Deployment/ArmorPaint
}
package() {
@@ -48,7 +45,7 @@ package() {
mkdir -p ${pkgdir}/usr/lib/armorpaint
install -Dm755 ${srcdir}/armorpaint.sh ${pkgdir}/usr/bin/armorpaint
install -Dm644 LICENSE.md ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- install -Dm755 armorcore/Deployment/Krom ${pkgdir}/usr/lib/armorpaint/
+ install -Dm755 armorcore/Deployment/ArmorPaint ${pkgdir}/usr/lib/armorpaint/
install -Dm644 ${srcdir}/armorpaint.desktop ${pkgdir}/usr/share/applications/armorpaint.desktop
mkdir -p ${pkgdir}/usr/share/armorpaint
cp -r build/krom ${pkgdir}/usr/share/armorpaint/krom
diff --git a/armorpaint.sh b/armorpaint.sh
index 0707725128d9..d719d7335bd7 100644
--- a/armorpaint.sh
+++ b/armorpaint.sh
@@ -1,3 +1,3 @@
#!/bin/bash
-/usr/lib/armorpaint/Krom /usr/share/armorpaint/krom
+/usr/lib/armorpaint/ArmorPaint /usr/share/armorpaint/krom