summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
-rw-r--r--arno-iptables-firewall.patch8
3 files changed, 10 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b3e3f89ee560..c9d4941539fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = arno-iptables-firewall
pkgdesc = A secure stateful firewall for both single and multi-homed machine
- pkgver = 2.1.1
+ pkgver = 2.1.1_a
pkgrel = 1
url = https://github.com/arno-iptables-firewall/aif/
arch = any
license = GPL
- makedepends = patch
depends = iptables
depends = iproute2
backup = etc/arno-iptables-firewall/firewall.conf
@@ -31,10 +30,7 @@ pkgbase = arno-iptables-firewall
backup = etc/arno-iptables-firewall/plugins/traffic-shaper.conf
backup = etc/arno-iptables-firewall/plugins/transparent-dnat.conf
backup = etc/arno-iptables-firewall/plugins/transparent-proxy.conf
- source = arno-iptables-firewall-2.1.1.tar.gz::https://github.com/arno-iptables-firewall/aif/archive/2.1.1.tar.gz
- source = arno-iptables-firewall.patch
- sha256sums = 6f5ae0e671b8ded8eb80efa48d4d0aa50324acde6ffdc4b3d34c7f8cc4fce598
- sha256sums = fbac95bced8565b00f5ff7b403579b1aaf7d386deb61c0f4a9acf50408a8200d
+ source = arno-iptables-firewall-2.1.1_a.tar.gz::https://github.com/arno-iptables-firewall/aif/archive/2.1.1a.tar.gz
+ sha256sums = 68aa1f3b22c13bcdb24af71ea5796041f059cecac8d601444cb56133d1d969c9
pkgname = arno-iptables-firewall
-
diff --git a/PKGBUILD b/PKGBUILD
index b2e31e23a344..386370c79b25 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
-# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Maintainer: DaarkWel <daarkwel at mail dot ru>
+# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
# Contributor: Arto Puranen <purcher@gmail.com>
pkgname=arno-iptables-firewall
-pkgver=2.1.1
+pkgver=2.1.1_a
pkgrel=1
pkgdesc="A secure stateful firewall for both single and multi-homed machine"
arch=('any')
url="https://github.com/arno-iptables-firewall/aif/"
license=('GPL')
depends=('iptables' 'iproute2')
-makedepends=('patch')
backup=(etc/${pkgname}/firewall.conf
etc/${pkgname}/custom-rules
etc/${pkgname}/plugins/dmz-dnat.conf
@@ -33,19 +33,11 @@ backup=(etc/${pkgname}/firewall.conf
etc/${pkgname}/plugins/traffic-shaper.conf
etc/${pkgname}/plugins/transparent-dnat.conf
etc/${pkgname}/plugins/transparent-proxy.conf)
-source=($pkgname-$pkgver.tar.gz::https://github.com/arno-iptables-firewall/aif/archive/${pkgver}.tar.gz
- $pkgname.patch)
-sha256sums=('6f5ae0e671b8ded8eb80efa48d4d0aa50324acde6ffdc4b3d34c7f8cc4fce598'
- 'fbac95bced8565b00f5ff7b403579b1aaf7d386deb61c0f4a9acf50408a8200d')
-
-prepare() {
- cd "${srcdir}"/aif-${pkgver}
-
- patch -Np0 -i "${srcdir}"/${pkgname}.patch
-}
+source=($pkgname-$pkgver.tar.gz::https://github.com/arno-iptables-firewall/aif/archive/${pkgver//_/}.tar.gz)
+sha256sums=('68aa1f3b22c13bcdb24af71ea5796041f059cecac8d601444cb56133d1d969c9')
package() {
- cd "${srcdir}"/aif-${pkgver}
+ cd "${srcdir}"/aif-${pkgver//_/}
# conf files
install -d -m 0755 etc/${pkgname}/plugins/ "${pkgdir}"/etc/${pkgname}/plugins/
@@ -74,7 +66,7 @@ package() {
install -Dm0644 share/man/man8/${pkgname}.8 "${pkgdir}"/usr/share/man/man8/${pkgname}.8
# systemd script
- install -Dm0644 "${srcdir}"/aif-${pkgver}/lib/systemd/system/${pkgname}.service \
+ install -Dm0644 "${srcdir}"/aif-${pkgver//_/}/lib/systemd/system/${pkgname}.service \
"${pkgdir}"/usr/lib/systemd/system/${pkgname}.service
sed 's|local/s||g' -i "${pkgdir}"/usr/lib/systemd/system/${pkgname}.service
}
diff --git a/arno-iptables-firewall.patch b/arno-iptables-firewall.patch
deleted file mode 100644
index 404f4b24aff7..000000000000
--- a/arno-iptables-firewall.patch
+++ /dev/null
@@ -1,8 +0,0 @@
---- etc/arno-iptables-firewall/firewall.conf.orig 2015-10-01 16:58:12.000000000 +0200
-+++ etc/arno-iptables-firewall/firewall.conf 2015-11-14 13:05:29.748859879 +0100
-@@ -235 +235 @@
--ENV_FILE="/usr/local/share/arno-iptables-firewall/environment"
-+ENV_FILE="/usr/share/arno-iptables-firewall/environment"
-@@ -239 +239 @@
--PLUGIN_BIN_PATH="/usr/local/share/arno-iptables-firewall/plugins"
-+PLUGIN_BIN_PATH="/usr/share/arno-iptables-firewall/plugins"