summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD35
-rw-r--r--arno-iptables-firewall.patch25
-rw-r--r--arno-iptables-firewall.service14
4 files changed, 26 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd463ec4da8a..4278077cddc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = arno-iptables-firewall
pkgdesc = A secure stateful firewall for both single and multi-homed machine
- pkgver = 2.0.1e
+ pkgver = 2.0.1f
pkgrel = 1
url = http://rocky.eld.leidenuniv.nl/joomla/
arch = any
@@ -25,12 +25,10 @@ pkgbase = arno-iptables-firewall
backup = etc/arno-iptables-firewall/plugins/traffic-shaper.conf
backup = etc/arno-iptables-firewall/plugins/transparent-dnat.conf
backup = etc/arno-iptables-firewall/plugins/transparent-proxy.conf
- source = http://rocky.eld.leidenuniv.nl/arno-iptables-firewall/arno-iptables-firewall_2.0.1e.tar.gz
+ source = http://rocky.eld.leidenuniv.nl/arno-iptables-firewall/arno-iptables-firewall_2.0.1f.tar.gz
source = arno-iptables-firewall.patch
- source = arno-iptables-firewall.service
- sha256sums = fa7b865e5d9b8e077cba73b2f28695a2fd691092a0a7f9e1c16ee369fc27fe43
- sha256sums = f1c09af1470354aa8b1a506cd97d1a5c2f95599db896e6dbde7dd506d4c85d1d
- sha256sums = 8c35a221ae7bb4b8abda923590b8bfab856dcc4d3f85991eebb37314efd1931c
+ sha256sums = 198848b8241b31f8498b43517af13879f55e00d17edfc6647ca48b43af2789a9
+ sha256sums = fbac95bced8565b00f5ff7b403579b1aaf7d386deb61c0f4a9acf50408a8200d
pkgname = arno-iptables-firewall
diff --git a/PKGBUILD b/PKGBUILD
index f494e85ac24a..d1185d3e5398 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Arto Puranen <purcher@gmail.com>
pkgname=arno-iptables-firewall
-pkgver=2.0.1e
+pkgver=2.0.1f
pkgrel=1
pkgdesc="A secure stateful firewall for both single and multi-homed machine"
arch=('any')
@@ -27,11 +27,10 @@ backup=(etc/${pkgname}/firewall.conf
etc/${pkgname}/plugins/traffic-shaper.conf
etc/${pkgname}/plugins/transparent-dnat.conf
etc/${pkgname}/plugins/transparent-proxy.conf)
-source=(http://rocky.eld.leidenuniv.nl/${pkgname}/${pkgname}_${pkgver}.tar.gz
- ${pkgname}.patch ${pkgname}.service)
-sha256sums=('fa7b865e5d9b8e077cba73b2f28695a2fd691092a0a7f9e1c16ee369fc27fe43'
- 'f1c09af1470354aa8b1a506cd97d1a5c2f95599db896e6dbde7dd506d4c85d1d'
- '8c35a221ae7bb4b8abda923590b8bfab856dcc4d3f85991eebb37314efd1931c')
+source=(http://rocky.eld.leidenuniv.nl/$pkgname/${pkgname}_${pkgver}.tar.gz
+ ${pkgname}.patch)
+sha256sums=('198848b8241b31f8498b43517af13879f55e00d17edfc6647ca48b43af2789a9'
+ 'fbac95bced8565b00f5ff7b403579b1aaf7d386deb61c0f4a9acf50408a8200d')
package() {
cd "${srcdir}"/${pkgname}_${pkgver}
@@ -42,29 +41,31 @@ package() {
# conf files
install -d -m 0755 etc/${pkgname}/plugins/ "${pkgdir}"/etc/${pkgname}/plugins/
for i in `find etc/${pkgname} -type f`; do install -T -m 0600 $i "${pkgdir}"/$i ;done
- install -D -m 0644 share/${pkgname}/environment "${pkgdir}"/usr/share/${pkgname}/environment
+ install -Dm0644 share/${pkgname}/environment "${pkgdir}"/usr/share/${pkgname}/environment
# plugins
install -d -m 0755 share/${pkgname}/plugins/ "${pkgdir}"/usr/share/${pkgname}/plugins/
for i in share/${pkgname}/plugins/*plugin; do install -T -m 0644 $i "${pkgdir}"/usr/$i ;done
- install -D -m 0744 share/${pkgname}/plugins/dyndns-host-open-helper \
+ install -Dm0744 share/${pkgname}/plugins/dyndns-host-open-helper \
"${pkgdir}"/usr/share/${pkgname}/plugins/dyndns-host-open-helper
- install -D -m 0744 share/${pkgname}/plugins/traffic-accounting-helper \
+ install -Dm0744 share/${pkgname}/plugins/traffic-accounting-helper \
"${pkgdir}"/usr/share/${pkgname}/plugins/traffic-accounting-helper
- install -D -m 0744 share/${pkgname}/plugins/traffic-accounting-log-rotate \
+ install -Dm0744 share/${pkgname}/plugins/traffic-accounting-log-rotate \
"${pkgdir}"/usr/share/${pkgname}/plugins/traffic-accounting-log-rotate
- install -D -m 0744 share/${pkgname}/plugins/traffic-accounting-show \
+ install -Dm0744 share/${pkgname}/plugins/traffic-accounting-show \
"${pkgdir}"/usr/share/${pkgname}/plugins/traffic-accounting-show
# binary
- install -D -m 0744 bin/${pkgname} "${pkgdir}"/usr/bin/${pkgname}
- install -D -m 0744 bin/arno-fwfilter "${pkgdir}"/usr/bin/arno-fwfilter
- install -D -m 0744 contrib/adsl-failover "${pkgdir}"/usr/bin/adsl-failover
+ install -Dm0744 bin/${pkgname} "${pkgdir}"/usr/bin/${pkgname}
+ install -Dm0744 bin/arno-fwfilter "${pkgdir}"/usr/bin/arno-fwfilter
+ install -Dm0744 contrib/adsl-failover "${pkgdir}"/usr/bin/adsl-failover
# man files
- install -D -m 0644 share/man/man1/arno-fwfilter.1 "${pkgdir}"/usr/share/man/man1/arno-fwfilter.1
- install -D -m 0644 share/man/man8/${pkgname}.8 "${pkgdir}"/usr/share/man/man8/${pkgname}.8
+ install -Dm0644 share/man/man1/arno-fwfilter.1 "${pkgdir}"/usr/share/man/man1/arno-fwfilter.1
+ install -Dm0644 share/man/man8/${pkgname}.8 "${pkgdir}"/usr/share/man/man8/${pkgname}.8
# systemd script
- install -D -m 0644 "${srcdir}"/${pkgname}.service "${pkgdir}"/usr/lib/systemd/system/${pkgname}.service
+ install -Dm0644 "${srcdir}"/${pkgname}_${pkgver}/lib/systemd/system/${pkgname}.service \
+ "${pkgdir}"/usr/lib/systemd/system/${pkgname}.service
+ sed 's|local/s||g' -i "${pkgdir}"/usr/lib/systemd/system/${pkgname}.service
}
diff --git a/arno-iptables-firewall.patch b/arno-iptables-firewall.patch
index 298d0c0b8d8e..404f4b24aff7 100644
--- a/arno-iptables-firewall.patch
+++ b/arno-iptables-firewall.patch
@@ -1,25 +1,8 @@
---- etc/arno-iptables-firewall/firewall.conf 2010-12-30 13:17:02.000000000 +0100
-+++ etc/arno-iptables-firewall/firewall.conf 2011-01-22 21:10:39.000000000 +0100
-@@ -233,18 +233,18 @@
- # 'whereis iptables' to manually locate it), required for (default) IPv4 support
- # -----------------------------------------------------------------------------
--IP4TABLES="/sbin/iptables"
-+IP4TABLES="/usr/bin/iptables"
-
- # (EXPERT SETTING!) Location of the ip6tables-binary (use 'locate ip6tables' or
- # 'whereis ip6tables' to manually locate it), required for IPv6 support
- # -----------------------------------------------------------------------------
--IP6TABLES="/sbin/ip6tables"
-+IP6TABLES="/usr/bin/ip6tables"
-
- # (EXPERT SETTING!) Location of the environment file
- # -----------------------------------------------------------------------------
+--- etc/arno-iptables-firewall/firewall.conf.orig 2015-10-01 16:58:12.000000000 +0200
++++ etc/arno-iptables-firewall/firewall.conf 2015-11-14 13:05:29.748859879 +0100
+@@ -235 +235 @@
-ENV_FILE="/usr/local/share/arno-iptables-firewall/environment"
+ENV_FILE="/usr/share/arno-iptables-firewall/environment"
-
- # (EXPERT SETTING!) Location of plugin binary & config files
- # -----------------------------------------------------------------------------
+@@ -239 +239 @@
-PLUGIN_BIN_PATH="/usr/local/share/arno-iptables-firewall/plugins"
+PLUGIN_BIN_PATH="/usr/share/arno-iptables-firewall/plugins"
- PLUGIN_CONF_PATH="/etc/arno-iptables-firewall/plugins"
-
diff --git a/arno-iptables-firewall.service b/arno-iptables-firewall.service
deleted file mode 100644
index 2d81c9869ec1..000000000000
--- a/arno-iptables-firewall.service
+++ /dev/null
@@ -1,14 +0,0 @@
-[Unit]
-Description=A secure stateful firewall for both single and multi-homed machine
-Before=network.target
-Wants=network.target
-
-[Service]
-Type=oneshot
-ExecStart=/usr/bin/arno-iptables-firewall start
-ExecStop=/usr/bin/arno-iptables-firewall stop
-ExecReload=/usr/bin/arno-iptables-firewall force-reload
-RemainAfterExit=yes
-
-[Install]
-WantedBy=multi-user.target