summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b471fad1646f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = arsenic
+ pkgdesc = Qt5 app for encrypt files and text with triple encryption
+ pkgver = 2.7
+ pkgrel = 1
+ url = https://github.com/Antidote1911/arsenic
+ arch = x86_64
+ license = GPL
+ depends = qt5-base
+ source = arsenic-v2.7.tar.gz::https://github.com/Antidote1911/arsenic/archive/v2.7/arsenic-v2.7.tar.gz
+ sha256sums = E7C0105CF68EC20B0AE86473558EE8EEC45FF2DAB6C03603BDA5428EB72E889B
+
+pkgname = arsenic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99fc79af5c4d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Fabrice Corraire <antidote1911@gmail.com>
+
+pkgname=arsenic
+pkgver=2.7
+pkgrel=1
+pkgdesc="Qt5 app for encrypt files and text with triple encryption"
+arch=('x86_64')
+url="https://github.com/Antidote1911/${pkgname}"
+license=('GPL')
+depends=('qt5-base')
+source=("${pkgname}-v${pkgver}.tar.gz::https://github.com/Antidote1911/${pkgname}/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
+sha256sums=('E7C0105CF68EC20B0AE86473558EE8EEC45FF2DAB6C03603BDA5428EB72E889B')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ qmake-qt5 QMAKE_DEFAULT_INCDIRS="" ${pkgname}.pro
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make INSTALL_ROOT="${pkgdir}/" install
+}