summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD56
-rwxr-xr-xartemis36
-rw-r--r--artemis3.desktop11
-rw-r--r--artemis3.install6
-rw-r--r--artemis3.sysusers1
-rw-r--r--fixbuild.patch15
7 files changed, 128 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9990f4b3c39c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = artemis3
+ pkgdesc = Radio Signals Recognition Manual
+ pkgver = 3.2.1
+ pkgrel = 1
+ url = https://aresvalley.com/
+ install = artemis3.install
+ arch = x86_64
+ license = GPL3
+ makedepends = pyinstaller
+ makedepends = patch
+ depends = glibc>=2.27
+ depends = python>=3.7.0
+ depends = python-numpy>=1.17.2
+ depends = python-pandas>=0.24.2
+ depends = python-certifi>=2019.6.16
+ depends = python-aiohttp>=3.5.4
+ depends = python-urllib3>=1.24.3
+ depends = python-pygame>=1.9.6
+ depends = python-qtawesome>=0.6.0
+ depends = python-pyqt5>=5.12.2
+ source = https://github.com/AresValley/Artemis/archive/v3.2.1.tar.gz
+ source = artemis3
+ source = artemis3.sysusers
+ source = artemis3.desktop
+ source = fixbuild.patch
+ md5sums = 22148f072132874ceae8afd7aad6b338
+ md5sums = 6500442c974df277f8baf40840126dad
+ md5sums = 375ed363a89e74943e4795486662e0c1
+ md5sums = d6983e6f3123d95ca29e89405993d7f1
+ md5sums = c3e46bdc63a33a07b06f644166bcd57a
+
+pkgname = artemis3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4dba7e240a27
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+pkgname=artemis3
+pkgver=3.2.1
+pkgrel=1
+pkgdesc="Radio Signals Recognition Manual"
+url="https://aresvalley.com/"
+license=(GPL3)
+arch=(x86_64)
+depends=('glibc>=2.27' 'python>=3.7.0' 'python-numpy>=1.17.2' 'python-pandas>=0.24.2' 'python-certifi>=2019.6.16' 'python-aiohttp>=3.5.4' 'python-urllib3>=1.24.3' 'python-pygame>=1.9.6' 'python-qtawesome>=0.6.0' 'python-pyqt5>=5.12.2')
+makedepends=(pyinstaller patch)
+source=("https://github.com/AresValley/Artemis/archive/v${pkgver}.tar.gz"
+ "artemis3"
+ "artemis3.sysusers"
+ "artemis3.desktop"
+ "fixbuild.patch")
+install=artemis3.install
+md5sums=('22148f072132874ceae8afd7aad6b338'
+ '6500442c974df277f8baf40840126dad'
+ '375ed363a89e74943e4795486662e0c1'
+ 'd6983e6f3123d95ca29e89405993d7f1'
+ 'c3e46bdc63a33a07b06f644166bcd57a')
+
+prepare() {
+ cd "${srcdir}/Artemis-${pkgver}"
+
+ patch -Np0 -i "${srcdir}/fixbuild.patch"
+}
+
+build() {
+ cd "${srcdir}/Artemis-${pkgver}/spec_files/Linux"
+
+ pyinstaller Artemis.spec
+}
+
+package() {
+ cd "${srcdir}/Artemis-${pkgver}"
+
+ # install basic stuff
+ mkdir -p "${pkgdir}/opt/${pkgname}"
+
+ install -Dm755 "${srcdir}/artemis3" "${pkgdir}/usr/bin/artemis3"
+ install -Dm755 "spec_files/Linux/dist/Artemis" "${pkgdir}/opt/${pkgname}/Artemis"
+ cp -ar "src/themes" "${pkgdir}/opt/${pkgname}/"
+
+ # install desktop entries and icons
+ install -Dm644 "spec_files/Linux/artemis3.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/artemis3.svg"
+ install -Dm644 "${srcdir}/artemis3.desktop" "${pkgdir}/usr/share/applications/artemis3.desktop"
+
+ # create group
+ install -Dm644 "${srcdir}/artemis3.sysusers" "${pkgdir}/usr/lib/sysusers.d/artemis3.conf"
+
+ # fix permissions
+ chown -R root:2008 "${pkgdir}/opt/${pkgname}"
+ chmod -R g+w "${pkgdir}/opt/${pkgname}"
+}
diff --git a/artemis3 b/artemis3
new file mode 100755
index 000000000000..84ff6eda081c
--- /dev/null
+++ b/artemis3
@@ -0,0 +1,6 @@
+#!/usr/bin/env bash
+
+cd /opt/artemis3
+/opt/artemis3/Artemis "$@"
+
+exit 0
diff --git a/artemis3.desktop b/artemis3.desktop
new file mode 100644
index 000000000000..2a58f26645d5
--- /dev/null
+++ b/artemis3.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Artemis
+GenericName=Artemis
+Type=Application
+Comment="Radio Signals Recognition Manual"
+StartupWMClass=artemis3
+Exec=sh -c "cd /opt/artemis3; ./Artemis"
+Terminal=false
+Icon=artemis3
+Categories=Network;HamRadio;
diff --git a/artemis3.install b/artemis3.install
new file mode 100644
index 000000000000..3a793ac103fe
--- /dev/null
+++ b/artemis3.install
@@ -0,0 +1,6 @@
+post_install() {
+ echo ""
+
+ echo "Don't forget to add yourself to the 'artemis3' group and re-login in order to be able to use Artemis properly."
+ echo ""
+}
diff --git a/artemis3.sysusers b/artemis3.sysusers
new file mode 100644
index 000000000000..3bc47b6ba2f5
--- /dev/null
+++ b/artemis3.sysusers
@@ -0,0 +1 @@
+g artemis3 2008 -
diff --git a/fixbuild.patch b/fixbuild.patch
new file mode 100644
index 000000000000..a392a2ffd8f8
--- /dev/null
+++ b/fixbuild.patch
@@ -0,0 +1,15 @@
+--- spec_files/Linux/Artemis.spec 2020-04-25 16:42:00.000000000 +0300
++++ spec_files/Linux/Artemis.spec 2020-05-12 16:28:16.470208875 +0300
+@@ -17,11 +17,11 @@
+
+ a = Analysis([SRC_PATH + 'artemis.py'], # noqa: 821
+ pathex=[os.getcwd()],
+ binaries=[],
+ datas=data_file,
+- hiddenimports=[],
++ hiddenimports=['packaging.requirements', 'pkg_resources.py2_warn'],
+ hookspath=[],
+ runtime_hooks=[],
+ excludes=[],
+ win_no_prefer_redirects=False,
+ win_private_assemblies=False,