summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
2 files changed, 11 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b64cd63af107..17f9e910ffc4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,15 @@
pkgbase = asap
pkgdesc = Another Slight Atari Player - library and players for 8-bit Atari music format
pkgver = 4.0.0
- pkgrel = 1
+ pkgrel = 2
url = http://asap.sourceforge.net
arch = i686
arch = x86_64
license = GPL
- makedepends = vlc
- makedepends = audacious
depends = glibc
options = staticlibs
source = http://downloads.sourceforge.net/asap/asap-4.0.0.tar.gz
- source = http://ftp.daper.net/pub/soft/moc/stable/moc-2.5.2.tar.bz2
sha256sums = 7612dc0251c13345bd17dbec46cdecd794a50cab5d4b7840471a6bed41933640
- sha256sums = f3a68115602a4788b7cfa9bbe9397a9d5e24c68cb61a57695d1c2c3ecf49db08
pkgname = asap
diff --git a/PKGBUILD b/PKGBUILD
index bff2f81d09d4..d64326aaba80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# Maintainer: nisk1 <esqueleto_bajo[it_looks_like_a_snail]outlook[dot]com>
# Uncomment any of below lines to build additional plugins:
-_build_vlc="yes"
-_build_moc="yes"
-_build_xmms="yes"
+#_build_vlc="yes"
+#_build_moc="yes"
+#_build_xmms="yes"
pkgname=asap
pkgver=4.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Another Slight Atari Player - library and players for 8-bit Atari music format"
url="http://asap.sourceforge.net"
arch=('i686' 'x86_64')
@@ -20,20 +20,21 @@ sha256sums=('7612dc0251c13345bd17dbec46cdecd794a50cab5d4b7840471a6bed41933640')
if [[ "$_build_vlc" = "yes" ]]; then
makedepends+=('vlc')
-fi
+fi
+
if [[ "$_build_moc" = "yes" ]]; then
- makedepends+=('audacious')
+ makedepends+=('moc')
source+=('http://ftp.daper.net/pub/soft/moc/stable/moc-2.5.2.tar.bz2')
sha256sums+=('f3a68115602a4788b7cfa9bbe9397a9d5e24c68cb61a57695d1c2c3ecf49db08')
fi
if [[ "$_build_xmms" = "yes" ]]; then
makedepends+=('xmms')
-fi
+fi
build() {
cd $srcdir/$pkgname-$pkgver/
- make
+ make
if [[ "$_build_vlc" = "yes" ]]; then
make asap-vlc
@@ -54,7 +55,7 @@ build() {
package() {
cd $srcdir/$pkgname-$pkgver/
make DESTDIR="${pkgdir}" prefix="/usr" install-asapconv install
-
+
if [[ "$_build_vlc" = "yes" ]]; then
make DESTDIR="${pkgdir}" prefix="/usr" install-vlc
fi