summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..157ab54230ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = asciigraph
+ pkgdesc = Go package to make lightweight ASCII line graph ╭┈╯ in command line apps with no other dependencies
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://github.com/guptarohit/asciigraph
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ source = asciigraph-0.4.1.tar.gz::https://github.com/guptarohit/asciigraph/archive/v0.4.1.tar.gz
+ md5sums = 6efaf8b04f7f55e4863ce3127aa2308c
+
+pkgname = asciigraph
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fbcbe59f2fde
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=asciigraph
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="Go package to make lightweight ASCII line graph ╭┈╯ in command line apps with no other dependencies"
+arch=('x86_64')
+url='https://github.com/guptarohit/asciigraph'
+license=('MIT')
+makedepends=('go')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/guptarohit/asciigraph/archive/v0.4.1.tar.gz")
+md5sums=('6efaf8b04f7f55e4863ce3127aa2308c')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ mkdir -p $srcdir/go
+ export GOPATH="${srcdir}"/go
+ export PATH=$PATH:$GOPATH/bin
+ go get -d -v ./...
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}/cmd/asciigraph"
+ go build -v -o "${srcdir}/asciigraph-bin"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm755 ../asciigraph-bin "${pkgdir}/usr/bin/asciigraph"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/asciigraph/LICENSE"
+ go clean -modcache #Remove go libraries
+} \ No newline at end of file