summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD17
3 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef865b515510
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = asciinema-edit
+ pkgdesc = asciinema casts post-production tools.
+ pkgver = 0.0.6
+ pkgrel = 1
+ url = https://github.com/cirocosta/asciinema-edit
+ arch = any
+ license = MIT
+ source = https://github.com/cirocosta/asciinema-edit/releases/download/0.0.6/asciinema-edit_0.0.6_linux_amd64.tar.gz
+ sha512sums = d99dac29a22532b3558ae59d8dfcfe08a227d64f10de4dda3be7cd17052ff303c12745d5a46fac269a9df143feb67c28b015bbadaa6f87d6f03b39193deca9a5
+
+pkgname = asciinema-edit
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b882a86e1487
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*pkg.tar.xz
+asciinema-edit_*_linux_amd64.tar.gz
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ae3cfc49531
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Malachi Soord <me@malachisoord.com>
+pkgname=asciinema-edit
+pkgver=0.0.6
+pkgrel=1
+pkgdesc="asciinema casts post-production tools."
+url="https://github.com/cirocosta/asciinema-edit"
+arch=('any')
+license=('MIT')
+
+source=("https://github.com/cirocosta/asciinema-edit/releases/download/${pkgver}/asciinema-edit_0.0.6_linux_amd64.tar.gz")
+sha512sums=('d99dac29a22532b3558ae59d8dfcfe08a227d64f10de4dda3be7cd17052ff303c12745d5a46fac269a9df143feb67c28b015bbadaa6f87d6f03b39193deca9a5')
+
+package() {
+ install -Dm755 "asciinema-edit" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}