summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b01702048c37
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = asciiquarium-lock
+ pkgdesc = Simple screen locker using ASCIIQuarium as a screensaver
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/YanDoroshenko/asciiquarium-lock
+ arch = any
+ license = GPL
+ depends = awk
+ depends = xtrlock
+ depends = asciiquarium
+ depends = xterm
+ depends = xorg-xserver
+ source = https://raw.githubusercontent.com/YanDoroshenko/asciiquarium-lock/master/asciiquarium-lock.sh
+ sha256sums = 6aea815606759713185a07b4d66e1c716aedeeac391ffd41ae45f8ac2c893665
+
+pkgname = asciiquarent-lock
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9edbae508a81
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Yan Doroshenko <yandoroshenko@protonmail.com>
+
+pkgname=asciiquarium-lock
+pkgver=1.0
+pkgrel=1
+pkgdesc="Simple screen locker using ASCIIQuarium as a screensaver"
+arch=('any')
+url="https://github.com/YanDoroshenko/asciiquarium-lock"
+license=('GPL')
+depends=('awk' 'asciiquarium' 'xterm' 'xtrlock' 'xorg-server')
+optdepends=('xkblayout-state: Restore the selected layout after unlock', 'xorg-xrandr: Multihead support')
+source=("https://github.com/YanDoroshenko/"$pkgname"/raw/master/"$pkgname".sh")
+sha256sums=('6aea815606759713185a07b4d66e1c716aedeeac391ffd41ae45f8ac2c893665')
+
+package() {
+ mkdir -p "$pkgdir"/usr/bin
+ cp "$pkgname".sh "$pkgdir"/usr/bin/"$pkgname"
+ chmod +x "$pkgdir"/usr/bin/"$pkgname"
+}