summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD8
-rw-r--r--changelog6
3 files changed, 20 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35ab9d8bb782..cada917502e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = asf
pkgdesc = Steam cards farmer.
- pkgver = 3.4.0.4
+ pkgver = 3.4.0.5
pkgrel = 1
url = https://github.com/JustArchiNET/ArchiSteamFarm
install = asf.install
@@ -10,9 +10,9 @@ pkgbase = asf
arch = i686
license = Apache
makedepends = p7zip
- noextract = asf-3.4.0.4-x86_64.zip
- noextract = asf-3.4.0.4-arm.zip
- noextract = asf-3.4.0.4-i686.zip
+ noextract = asf-3.4.0.5-x86_64.zip
+ noextract = asf-3.4.0.5-arm.zip
+ noextract = asf-3.4.0.5-i686.zip
backup = var/lib/asf/config/ASF.json
backup = usr/lib/asf/NLog.config
source = asf.sh
@@ -27,19 +27,19 @@ pkgbase = asf
sha256sums = 883373be23f6f49ae597f61c1310d8cd45bce7c3ee1b5d456ffc9fedbe7dd486
sha256sums = e63a92fd8008c40dab963161bdac967b57146553c00f114469c204ac6e1795b2
sha256sums = 9a10e9e6ff88fcc00000c12464ae2b650a3f075ef7e440088414b46c41214ee4
- source_x86_64 = asf-3.4.0.4-x86_64.zip::https://github.com/JustArchiNET/ArchiSteamFarm/releases/download/3.4.0.4/ASF-linux-x64.zip
+ source_x86_64 = asf-3.4.0.5-x86_64.zip::https://github.com/JustArchiNET/ArchiSteamFarm/releases/download/3.4.0.5/ASF-linux-x64.zip
depends_x86_64 = dotnet-host
depends_x86_64 = libunwind
depends_x86_64 = openssl-1.0
- sha256sums_x86_64 = fa2e43711d60165406b3bb8b6f609f5f2407831a44730f46bc17fb330f8a343d
- source_arm = asf-3.4.0.4-arm.zip::https://github.com/JustArchiNET/ArchiSteamFarm/releases/download/3.4.0.4/ASF-linux-arm.zip
+ sha256sums_x86_64 = b5c0bd979d062f1b1e0df62da845000d90df97f5f457502595e4b2f9d8632217
+ source_arm = asf-3.4.0.5-arm.zip::https://github.com/JustArchiNET/ArchiSteamFarm/releases/download/3.4.0.5/ASF-linux-arm.zip
depends_arm = dotnet-host
depends_arm = libunwind
depends_arm = openssl-1.0
- sha256sums_arm = 4f3bd47d94370025f137d6cc8da57ff0560e5d8da99894d4864e4e1c232d89de
- source_i686 = asf-3.4.0.4-i686.zip::https://github.com/JustArchiNET/ArchiSteamFarm/releases/download/3.4.0.4/ASF-generic.zip
+ sha256sums_arm = 2b38113cc013d68eead58912639caae06f9543181192e5ba0ec978cd06e33fce
+ source_i686 = asf-3.4.0.5-i686.zip::https://github.com/JustArchiNET/ArchiSteamFarm/releases/download/3.4.0.5/ASF-generic.zip
depends_i686 = dotnet-runtime
- sha256sums_i686 = 0abd9cfcf5cf2d7ded252eedf1941f3d77c87d5360fafabaf196c6dcf077fbf9
+ sha256sums_i686 = d0f4e70627ca3ddb3fbb5bd96213ba2aa38ad3bf4aa4225226ef06d95112fd04
pkgname = asf
diff --git a/PKGBUILD b/PKGBUILD
index 327f2b753be6..891da7c01271 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
pkgname="asf"
-pkgver="3.4.0.4"
+pkgver="3.4.0.5"
pkgrel=1
pkgdesc="Steam cards farmer."
arch=('x86_64' 'arm' 'i686')
@@ -29,9 +29,9 @@ sha256sums=('8d76996c1024b80704b25af8a8800ef3f8a8a518d19c2a1e85ba62b58b22cdfd'
'883373be23f6f49ae597f61c1310d8cd45bce7c3ee1b5d456ffc9fedbe7dd486'
'e63a92fd8008c40dab963161bdac967b57146553c00f114469c204ac6e1795b2'
'9a10e9e6ff88fcc00000c12464ae2b650a3f075ef7e440088414b46c41214ee4')
-sha256sums_x86_64=('fa2e43711d60165406b3bb8b6f609f5f2407831a44730f46bc17fb330f8a343d')
-sha256sums_arm=('4f3bd47d94370025f137d6cc8da57ff0560e5d8da99894d4864e4e1c232d89de')
-sha256sums_i686=('0abd9cfcf5cf2d7ded252eedf1941f3d77c87d5360fafabaf196c6dcf077fbf9')
+sha256sums_x86_64=('b5c0bd979d062f1b1e0df62da845000d90df97f5f457502595e4b2f9d8632217')
+sha256sums_arm=('2b38113cc013d68eead58912639caae06f9543181192e5ba0ec978cd06e33fce')
+sha256sums_i686=('d0f4e70627ca3ddb3fbb5bd96213ba2aa38ad3bf4aa4225226ef06d95112fd04')
noextract=("${source_x86_64[@]%%::*}" "${source_arm[@]%%::*}" "${source_i686[@]%%::*}")
prepare() {
diff --git a/changelog b/changelog
index 01f0020b60ea..7833a184fe3b 100644
--- a/changelog
+++ b/changelog
@@ -1,3 +1,9 @@
+2018-11-01 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
+ * 3.4.0.5-1:
+ We've improved our update process according to feedback of users that encountered some problems. If something doesn't work, we recommend to download this release (or newer) manually and copy over config directory. Not a lot of people got affected by this problem, so if everything works for you, you don't need to do anything.
+ Fixed restart command that we accidentally made to work the same as exit during our huge kestrel refactor, whoops (ref: #932).
+ Synced ASF-ui to latest release which should fix some issues that people have reported.
+ Other misc code improvements, optimizations and bugfixes.
2018-10-31 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
* 3.4.0.4-1:
[!] We've moved ASF project under JustArchiNET GitHub organization. This change should be mostly transparent for you as old URLs redirect appropriately. Only web config generator is no longer accessible under old URL, we've already updated all references (on wiki and alike). If you're using URL to our repo in your own projects, you might want to update them.