summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD4
-rw-r--r--changelog11
3 files changed, 17 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27aa2718eaca..353682486ba6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu May 12 19:01:28 UTC 2016
+# Fri Jun 3 12:48:52 UTC 2016
pkgbase = asf
pkgdesc = Steam cards farmer.
- pkgver = 2.0.4.4
+ pkgver = 2.0.5.1
pkgrel = 1
url = https://github.com/JustArchi/ArchiSteamFarm
install = asf.install
@@ -11,11 +11,11 @@ pkgbase = asf
license = Apache
depends = mono
backup = opt/asf/config/ASF.json
- source = https://github.com/JustArchi/ArchiSteamFarm/releases/download/2.0.4.4/ASF.zip
+ source = https://github.com/JustArchi/ArchiSteamFarm/releases/download/2.0.5.1/ASF.zip
source = asf.sh
source = asf-config.sh
source = asf.service
- sha256sums = be6e1df6321dce3e36edc643fe9e8f7e65fadb4d4f6562458b98ecb3986f96ee
+ sha256sums = 94b35364cc93204030a50ae68fc7c63a591b8ce1148e0faf627105d1374a6bfc
sha256sums = a5d0324c029efb1f99264e787fea26ad53953b4df59bf642bca1ffabad4027f5
sha256sums = 63b8d4718e8cc61016ef415ff418e6180102b077315f5ce77bfcab9c03433565
sha256sums = afeee8eb3f1bafa1b0502ce6be43e5119ab73fdc228a49990c9087462c5464af
diff --git a/PKGBUILD b/PKGBUILD
index 1496b55b3ebe..c5139cd92ec1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
pkgname="asf"
-pkgver="2.0.4.4"
+pkgver="2.0.5.1"
pkgrel=1
pkgdesc="Steam cards farmer."
arch=('any')
@@ -15,7 +15,7 @@ source=("https://github.com/JustArchi/ArchiSteamFarm/releases/download/${pkgver}
"${pkgname}.sh"
"${pkgname}-config.sh"
"${pkgname}.service")
-sha256sums=('be6e1df6321dce3e36edc643fe9e8f7e65fadb4d4f6562458b98ecb3986f96ee'
+sha256sums=('94b35364cc93204030a50ae68fc7c63a591b8ce1148e0faf627105d1374a6bfc'
'a5d0324c029efb1f99264e787fea26ad53953b4df59bf642bca1ffabad4027f5'
'63b8d4718e8cc61016ef415ff418e6180102b077315f5ce77bfcab9c03433565'
'afeee8eb3f1bafa1b0502ce6be43e5119ab73fdc228a49990c9087462c5464af')
diff --git a/changelog b/changelog
index 555ecd4cd7e7..7e0a13134bcb 100644
--- a/changelog
+++ b/changelog
@@ -1,4 +1,15 @@
2016-05-12 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
+ * 2.0.5.1:
+ Fixed harmless error when account was not using SteamApiKey, introduced in 2.0.5.0.
+ * 2.0.5.0:
+ [!] Greatly improved primary accounts support and removed AccountPlayingDelay global config property.
+ ASF will now ignore initial OnFarmingFinished() event when ShutdownOnFarmingFinished is set, and you've just !started this bot instance, allowing you to issue commands without much hassle. Every next event (including the one fired after IdleFarmingPeriod) will be honored.
+ !update command will now ignore (override) AutoUpdates setting, allowing you to force ASF update while still being able to skip automatic ones (on program startup and every 24 hours).
+ Fixed valid trades potentially being ignored in SteamTradeMatcher when user was overpaying with cards from the same game.
+ Fixed wrong dupes calculation when Steam is talking crap and responding with NULL instanceID of items (thanks GabeN).
+ Fixed ASF accidentally dismissing notifications related to profile comments.
+ Massive portion of code improvements, optimizations and bugfixes.
+2016-05-12 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
* 2.0.4.4:
ASF now allows only one trade to be sent in SendOnFarmingFinished when account did not farm anything - this cuts spam related to sending trade every IdleFarmingPeriod, while still sending initial trade after connect.
ASF now allows overpaying when SteamTradeMatcher is enabled.