summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD35
-rw-r--r--patch-a4g-a_opt.adb20
-rw-r--r--patch-a4g-a_opt.ads11
3 files changed, 52 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ab1a9b3b47eb..1b9995953ecb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=asis
pkgver=2015
-pkgrel=1
-pkgdesc="ASIS gives Ada applications access to the complete syntactic and semantic structure of an Ada compilation unit."
+pkgrel=2
+pkgdesc="Allows Ada programs access to the syntactic and semantic structure of source code. Also provides extra tools such as gnatpp."
arch=(i686 x86_64)
url=http://libre.adacore.com/tools/$_pkgname
@@ -19,27 +19,32 @@ conflicts=($pkgname)
source=(http://downloads.dragonlace.net/src/$pkgname-gpl-$pkgver-src.tar.gz
asis.gpr
patch-Makefile.stub
-)
+ patch-a4g-a_opt.ads
+ patch-a4g-a_opt.adb)
md5sums=('2c5a1f382bbf644bcdd2e6417f6d1e60'
'223d59aadef66852e7f0493bf6b01fee'
- '91e1338160c413a06031a547b4f84338')
+ '91e1338160c413a06031a547b4f84338'
+ '4608269e4e5bdd57cf8eabb2dc5c0041'
+ '210cbc83474488ebcfd9b72d1ccc3e43')
prepare()
{
- WRKSRC=$srcdir/$pkgname-gpl-$pkgver-src
+ WRKSRC=$srcdir/$pkgname-gpl-$pkgver-src
- sed -i -e 's|OPSYS|ASISOPSYS|g' \
- -e 's|(prefix)|(DESTDIR)$$(prefix)|g' \
- ${WRKSRC}/Makefile \
- ${WRKSRC}/Makefile.stub \
- ${WRKSRC}/common.gpr
+ sed -i -e 's|OPSYS|ASISOPSYS|g' \
+ -e 's|(prefix)|(DESTDIR)$$(prefix)|g' \
+ ${WRKSRC}/Makefile \
+ ${WRKSRC}/Makefile.stub \
+ ${WRKSRC}/common.gpr
- rm -rf ${WRKSRC}/gnat
+ rm -rf ${WRKSRC}/gnat
- cd $WRKSRC
- patch -p0 -i ../patch-Makefile.stub
+ cd $WRKSRC
+ patch -p0 -i ../patch-Makefile.stub
+ patch -p0 -i ../patch-a4g-a_opt.ads
+ patch -p0 -i ../patch-a4g-a_opt.adb
}
@@ -49,6 +54,7 @@ build()
cd $srcdir/$pkgname-gpl-$pkgver-src
make all
+ make tools
}
@@ -76,7 +82,8 @@ package()
${pkgdir}${DOCSDIR}/html \
${pkgdir}${DOCSDIR}/pdf
- ${INSTALL_PROGRAM} ${WRKSRC}/tools/asistant/asistant ${pkgdir}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/tools/asistant/asistant ${pkgdir}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/tools/gnatpp/gnatpp ${pkgdir}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/asis/*.ad[bs] ${pkgdir}${PREFIX}/include/asis
${INSTALL_DATA} ${WRKSRC}/lib/*.ali ${pkgdir}${PREFIX}/lib/asis
diff --git a/patch-a4g-a_opt.adb b/patch-a4g-a_opt.adb
new file mode 100644
index 000000000000..5a4e3efb40e0
--- /dev/null
+++ b/patch-a4g-a_opt.adb
@@ -0,0 +1,20 @@
+--- asis/a4g-a_opt.adb-orig 2015-11-04 08:07:22.751223374 +1100
++++ asis/a4g-a_opt.adb 2015-11-04 08:08:19.197892357 +1100
+@@ -175,7 +175,7 @@
+ when 's' =>
+
+ if Parameter = "-sv" then
+- Strong_Version_Check := True;
++ Strong_Version_Check := False;
+ else
+ Unknown_Parameter := True;
+ end if;
+@@ -241,7 +241,7 @@
+ begin
+ Is_Initialized := False;
+ ASIS_Warning_Mode := Normal;
+- Strong_Version_Check := True;
++ Strong_Version_Check := False;
+ Generate_Bug_Box := True;
+ Keep_Going := False;
+ end Set_Off;
diff --git a/patch-a4g-a_opt.ads b/patch-a4g-a_opt.ads
new file mode 100644
index 000000000000..592b20a6b836
--- /dev/null
+++ b/patch-a4g-a_opt.ads
@@ -0,0 +1,11 @@
+--- asis/a4g-a_opt.ads-old 2015-11-04 07:49:30.264512698 +1100
++++ asis/a4g-a_opt.ads 2015-11-04 07:49:54.257847015 +1100
+@@ -59,7 +59,7 @@
+ -- treated as an error: ASIS_Failed is raised and the warning message is
+ -- sent to an ASIS Diagnosis string.
+
+- Strong_Version_Check : Boolean := True;
++ Strong_Version_Check : Boolean := False;
+ -- Strong version check means that version strings read from the tree and
+ -- stored in Gnatvsn are compared. Weak check means comparing ASIS version
+ -- numbers. See BA23-002