summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD45
-rw-r--r--patch-Makefile53
-rw-r--r--patch-a4g-encl_el.adb19
4 files changed, 92 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32253185b592..4a2463baf92d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sun Jun 5 02:04:42 UTC 2016
pkgbase = asis
pkgdesc = Allows Ada programs access to the syntactic and semantic structure of source code. Also provides extra tools such as gnatpp.
- pkgver = 2015
- pkgrel = 2
+ pkgver = 2016
+ pkgrel = 1
url = http://libre.adacore.com/tools/
arch = i686
arch = x86_64
@@ -12,15 +14,19 @@ pkgbase = asis
depends = gnatcoll
provides = asis
conflicts = asis
- source = http://downloads.dragonlace.net/src/asis-gpl-2015-src.tar.gz
+ source = http://downloads.dragonlace.net/src/asis-gpl-2016-src.tar.gz
source = asis.gpr
+ source = patch-Makefile
source = patch-Makefile.stub
+ source = patch-a4g-encl_el.adb
source = patch-a4g-a_opt.ads
source = patch-a4g-a_opt.adb
md5sums = 2c5a1f382bbf644bcdd2e6417f6d1e60
md5sums = 223d59aadef66852e7f0493bf6b01fee
+ md5sums = 223d59aadef66852e7f0493bf6b01fee
md5sums = 91e1338160c413a06031a547b4f84338
md5sums = 4608269e4e5bdd57cf8eabb2dc5c0041
+ md5sums = 4608269e4e5bdd57cf8eabb2dc5c0041
md5sums = 210cbc83474488ebcfd9b72d1ccc3e43
pkgname = asis
diff --git a/PKGBUILD b/PKGBUILD
index 4181fec797a4..7806d5e11436 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Contributor: Rod Kay <charlie5 on #ada at freenode.net>
pkgname=asis
-pkgver=2015
-pkgrel=2
+pkgver=2016
+pkgrel=1
pkgdesc="Allows Ada programs access to the syntactic and semantic structure of source code. Also provides extra tools such as gnatpp."
arch=(i686 x86_64)
@@ -17,14 +17,18 @@ conflicts=($pkgname)
source=(http://downloads.dragonlace.net/src/$pkgname-gpl-$pkgver-src.tar.gz
asis.gpr
+ patch-Makefile
patch-Makefile.stub
+ patch-a4g-encl_el.adb
patch-a4g-a_opt.ads
patch-a4g-a_opt.adb)
md5sums=('2c5a1f382bbf644bcdd2e6417f6d1e60'
'223d59aadef66852e7f0493bf6b01fee'
+ '223d59aadef66852e7f0493bf6b01fee'
'91e1338160c413a06031a547b4f84338'
'4608269e4e5bdd57cf8eabb2dc5c0041'
+ '4608269e4e5bdd57cf8eabb2dc5c0041'
'210cbc83474488ebcfd9b72d1ccc3e43')
@@ -41,9 +45,11 @@ prepare()
rm -rf ${WRKSRC}/gnat
cd $WRKSRC
+ patch -p0 -i ../patch-Makefile
patch -p0 -i ../patch-Makefile.stub
patch -p0 -i ../patch-a4g-a_opt.ads
patch -p0 -i ../patch-a4g-a_opt.adb
+ patch -p0 -i ../patch-a4g-encl_el.adb
}
@@ -56,41 +62,12 @@ build()
make tools
}
-
+
package()
{
cd $srcdir/$pkgname-gpl-$pkgver-src
-# make install prefix=$pkgdir/usr
-
- # gprinstall seems to be malfunctioning, just install manually
- #
- PREFIX=/usr
- DOCSDIR=/usr/share/doc/asis/
- INSTALL_PROGRAM=install
- INSTALL_DATA=install
- WRKSRC=$srcdir/$pkgname-gpl-$pkgver-src
- FILESDIR=$srcdir/$pkgname-gpl-$pkgver-src
-
- mkdir -p ${pkgdir}${PREFIX}/bin \
- ${pkgdir}${PREFIX}/include/asis \
- ${pkgdir}${PREFIX}/lib/asis \
- ${pkgdir}${PREFIX}/lib/gnat \
- ${pkgdir}${PREFIX}/share/gps/plug-ins \
- ${pkgdir}${DOCSDIR}/html \
- ${pkgdir}${DOCSDIR}/pdf
-
- ${INSTALL_PROGRAM} ${WRKSRC}/tools/asistant/asistant ${pkgdir}${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/tools/gnatpp/gnatpp ${pkgdir}${PREFIX}/bin
-
- ${INSTALL_DATA} ${WRKSRC}/asis/*.ad[bs] ${pkgdir}${PREFIX}/include/asis
- ${INSTALL_DATA} ${WRKSRC}/lib/*.ali ${pkgdir}${PREFIX}/lib/asis
- ${INSTALL_DATA} ${WRKSRC}/lib/*.a ${pkgdir}${PREFIX}/lib/asis
- ${INSTALL_DATA} ${WRKSRC}/documentation/*.html ${pkgdir}${DOCSDIR}/html
- ${INSTALL_DATA} ${WRKSRC}/documentation/*.pdf ${pkgdir}${DOCSDIR}/pdf
- ${INSTALL_DATA} ${WRKSRC}/documentation/*.txt ${pkgdir}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/documentation/asis.xml ${pkgdir}${PREFIX}/share/gps/plug-ins
- ${INSTALL_DATA} $srcdir/asis.gpr ${pkgdir}${PREFIX}/lib/gnat
- ${INSTALL_DATA} ${FILESDIR}/common.gpr ${pkgdir}${PREFIX}/lib/gnat
+ PREFIX=/usr make install prefix=${pkgdir}/usr
+ PREFIX=/usr make install-tools prefix=${pkgdir}/usr
}
diff --git a/patch-Makefile b/patch-Makefile
new file mode 100644
index 000000000000..14292d71277b
--- /dev/null
+++ b/patch-Makefile
@@ -0,0 +1,53 @@
+*** Makefile 2016-06-04 13:24:14.729351920 +1000
+--- Makefile-new 2016-06-04 13:27:00.459358720 +1000
+***************
+*** 27,50 ****
+ # ==================================================== install
+
+ install-clean:
+! ifneq (,$(wildcard $(DESTDIR)$$(prefix)/lib/gnat/manifests/asislib))
+ -$(GPRINSTALL) --uninstall --prefix=$(DESTDIR)$$(prefix) \
+ --project-subdir=lib/gnat asislib
+ endif
+
+ install: install-clean
+! $(GPRINSTALL) -p -f --prefix=$(DESTDIR)$$(prefix) --sources-subdir=include/asis \
+ --lib-subdir=lib/asis --project-subdir=lib/gnat -XBLD=$(BLD) \
+ -XASISOPSYS=$(ASISOPSYS) -XASIS_COMPONENTS=lib build_asis.gpr
+
+ install-tools-clean:
+! ifneq (,$(wildcard $(DESTDIR)$$(prefix)/lib/gnat/manifests/asistools))
+! -$(GPRINSTALL) --uninstall --prefix=$(DESTDIR)$$(prefix) \
+ --project-subdir=lib/gnat asistools
+ endif
+
+ install-tools: install-tools-clean
+! $(GPRINSTALL) -p -f --prefix=$(DESTDIR)$$(prefix) --sources-subdir=include/asis \
+ --lib-subdir=lib/asis --project-subdir=lib/gnat -XBLD=$(BLD) \
+ -XASISOPSYS=$(ASISOPSYS) -XASIS_COMPONENTS=tools build_asis.gpr
+
+--- 27,50 ----
+ # ==================================================== install
+
+ install-clean:
+! ifneq (,$(wildcard $(DESTDIR)$(prefix)/lib/gnat/manifests/asislib))
+ -$(GPRINSTALL) --uninstall --prefix=$(DESTDIR)$$(prefix) \
+ --project-subdir=lib/gnat asislib
+ endif
+
+ install: install-clean
+! $(GPRINSTALL) -p -f --prefix=$(DESTDIR)$(prefix) --sources-subdir=include/asis \
+ --lib-subdir=lib/asis --project-subdir=lib/gnat -XBLD=$(BLD) \
+ -XASISOPSYS=$(ASISOPSYS) -XASIS_COMPONENTS=lib build_asis.gpr
+
+ install-tools-clean:
+! ifneq (,$(wildcard $(DESTDIR)$(prefix)/lib/gnat/manifests/asistools))
+! -$(GPRINSTALL) --uninstall --prefix=$(DESTDIR)$(prefix) \
+ --project-subdir=lib/gnat asistools
+ endif
+
+ install-tools: install-tools-clean
+! $(GPRINSTALL) -p -f --prefix=$(DESTDIR)$(prefix) --sources-subdir=include/asis \
+ --lib-subdir=lib/asis --project-subdir=lib/gnat -XBLD=$(BLD) \
+ -XASISOPSYS=$(ASISOPSYS) -XASIS_COMPONENTS=tools build_asis.gpr
+
diff --git a/patch-a4g-encl_el.adb b/patch-a4g-encl_el.adb
new file mode 100644
index 000000000000..349d426f5fde
--- /dev/null
+++ b/patch-a4g-encl_el.adb
@@ -0,0 +1,19 @@
+*** asis/a4g-encl_el.adb 2016-05-16 19:17:27.000000000 +1000
+--- asis/a4g-encl_el.adb-new 2016-06-04 11:32:33.972410280 +1000
+***************
+*** 2798,2804 ****
+
+ if Nkind (Rough_Result_Node) = N_Subprogram_Body
+ and then not (Comes_From_Source (Rough_Result_Node))
+! and then Was_Expression_Function (Rough_Result_Node)
+ then
+ Set_Int_Kind
+ (Rough_Result_Element, An_Expression_Function_Declaration);
+--- 2798,2804 ----
+
+ if Nkind (Rough_Result_Node) = N_Subprogram_Body
+ and then not (Comes_From_Source (Rough_Result_Node))
+! and then Sinfo.Was_Expression_Function (Rough_Result_Node)
+ then
+ Set_Int_Kind
+ (Rough_Result_Element, An_Expression_Function_Declaration);