summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD40
2 files changed, 24 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a9623ef36c6..333ce5432afa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = asix-ax88179-dkms
- pkgdesc = Driver for USB ASIX Ethernet model AX88179/AX88178A
+ pkgdesc = A kernel module for ASIX AX88178A AX88179 USB 3.0 network adapters
pkgver = 1.19.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.asix.com.tw/
arch = i686
arch = x86_64
license = GPL
depends = dkms
- source = http://www.asix.com.tw/FrootAttach/driver/AX88179_178A_LINUX_DRIVER_v1.19.0_SOURCE.tar.bz2
+ source = https://www.asix.com.tw/FrootAttach/driver/AX88179_178A_LINUX_DRIVER_v1.19.0_SOURCE.tar.bz2
source = asix-ax88179-dkms.conf
source = 0001-No-date-time.patch
source = 0002-b2b128.patch
diff --git a/PKGBUILD b/PKGBUILD
index 9458424dcb5a..4aae8726714a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=asix-ax88179-dkms
pkgver=1.19.0
-pkgrel=1
-pkgdesc="Driver for USB ASIX Ethernet model AX88179/AX88178A"
+pkgrel=2
+pkgdesc="A kernel module for ASIX AX88178A AX88179 USB 3.0 network adapters"
arch=('i686' 'x86_64')
_filename="AX88179_178A_LINUX_DRIVER_v${pkgver}_SOURCE"
@@ -12,7 +12,7 @@ _modname='ax88179_178a'
# Browse the pages for USB-to-Ethernet devices and see which devices are
# compatible with this driver.
-# http://www.asix.com.tw/download.php?sub=driverdetail&PItemID=131
+# https://www.asix.com.tw/download.php?sub=driverdetail&PItemID=131
url='http://www.asix.com.tw/'
license=('GPL')
@@ -21,7 +21,7 @@ depends=('dkms')
_filename="AX88179_178A_LINUX_DRIVER_v${pkgver}_SOURCE"
_modname='ax88179_178a'
source=(
- "http://www.asix.com.tw/FrootAttach/driver/${_filename}.tar.bz2"
+ "https://www.asix.com.tw/FrootAttach/driver/${_filename}.tar.bz2"
"${pkgname}.conf"
"0001-No-date-time.patch"
"0002-b2b128.patch"
@@ -53,8 +53,10 @@ prepare() {
}
package() {
+ # We are in the source directory ./src/
+ # Please note the source of the driver are in a subfolder:
+ # i.e.: src/AX88772C_772B_772A_760_772_178_Linux_Driver_v<version>_Source/
installDir="${pkgdir}/usr/src/${_modname}-dkms-${pkgver}"
-
install -dm755 "${installDir}"
# The kernel from kernel.org does provide an outdated module ax88179_178a.
@@ -79,25 +81,25 @@ package() {
sed -e "s/@PKGVER@/${pkgver}/" \
-i "${installDir}/dkms.conf"
- # Install module source
+ # Install module sources
cd "${srcdir}/${_filename}"
- # We could use a simple 'cp' here as even if we have a custom umask,
- # makepkg is redefining his own umask value 0022.
+ # 'cp' would have the same effect as 'install' here, because, even if we
+ # had defined a custom umask in our shell startup scripts, makepkg is
+ # redefining his own umask value 0022.
# src.: https://git.archlinux.org/pacman.git/tree/scripts/makepkg.sh.in?id=4f2fea240d3039294f6614003206a3dd1f67cfc5#n1255
- # Also, if we were using a simple 'cp', we would have relied upon upstream
- # providing a tar archive with the rights we want (755 for folders and 644
- # for files). While this is currently the case for now, if upstream does
- # not respect these rights, here, we are making sure we have the rights we
- # want.
- # And use a 'while' loop with 'read' and process substitution to harden
- # this script when special chars are used.
+ # Also, if we were using a simple 'cp', we would have to rely on upstream
+ # providing the correct rights for us. While this is technically the case
+ # for now, using 'install' ensures we are using the correct rights even if
+ # upstream weren't.
+ # We are using a 'while' loop with 'read' and process substitution in order to harden this
+ # script in the event special chars were to be used.
# src.: http://mywiki.wooledge.org/BashPitfalls#line-92
- while IFS= read -r -d '' d; do
- install -dm755 "${installDir}/$d"
+ while IFS= read -r -d '' directory; do
+ install -dm755 "${installDir}/${directory}"
done < <(find . -type d -print0)
- while IFS= read -r -d '' f; do
- install -m644 "${srcdir}/${_filename}/$f" "${installDir}/$f"
+ while IFS= read -r -d '' file; do
+ install -m644 "${srcdir}/${_filename}/${file}" "${installDir}/${file}"
done < <(find . -type f -print0)
}