summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rwxr-xr-xPKGBUILD42
-rwxr-xr-xaster.install32
3 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..19bf44f1f05e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = aster
+ pkgdesc = Code-Aster
+ pkgver = 11.7.0
+ pkgrel = 1
+ url = http://www.code-aster.org/
+ install = aster.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2
+ depends = astk>=1.13.4
+ depends = metis4
+ depends = med>=3.0.7
+ depends = mumps>=4.10.0-7
+ options = !strip
+ source = http://www.code-aster.org/FICHIERS/aster-full-src-11.7.0-1.noarch.tar.gz
+ md5sums = 469a89d443d8a7ea6d95a2e5671628a8
+
+pkgname = aster
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..55f9b23ecc59
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Michele Mocciola <mickele>
+pkgname=aster
+pkgver=11.7.0
+pkgrel=1
+pkgdesc="Code-Aster"
+url="http://www.code-aster.org/"
+license="GPL"
+depends=('python2' 'astk>=1.13.4' 'metis4' 'med>=3.0.7' 'mumps>=4.10.0-7')
+makedepends=()
+install="${pkgname}.install"
+arch=('i686' 'x86_64')
+source=('http://www.code-aster.org/FICHIERS/aster-full-src-11.7.0-1.noarch.tar.gz')
+options=(!strip)
+
+_sourcedir=
+_installdir=/usr
+_installsuff=STA11.7
+
+prepare(){
+ cd "${srcdir}"
+ tar xzf "${srcdir}/aster-full-src-${pkgver}/SRC/aster-${pkgver}.tgz"
+}
+
+build() {
+ cd "${srcdir}"
+
+ cd "${srcdir}/aster-${pkgver}"
+ INCLUDES="/usr/include/metis-4 /usr/include" PYTHON="/usr/bin/python2" LRELEASE="lrelease-qt4" python2 waf configure --prefix="${pkgdir}${_installdir}" --enable-mumps --metis-libs=metis-4 --scotch-libs='esmumps scotch bz2 scotcherr' --install-as=${_installsuff} --embed-aster
+ python2 waf build
+ python2 waf build_debug
+}
+
+package() {
+ cd "${srcdir}/aster-${pkgver}"
+ python2 waf install --install-tests
+ python2 waf install_debug
+ for _FILE in share/aster/${_installsuff}/profile.sh share/aster/${_installsuff}/config.txt include/aster/${_installsuff}/asterf_config.h include/aster/${_installsuff}/asterc_config.h lib/aster/${_installsuff}/aster_pkginfo.py
+ do
+ sed -e "s|${pkgdir}||g" -i "${pkgdir}${_installdir}/${_FILE}"
+ done
+}
+md5sums=('469a89d443d8a7ea6d95a2e5671628a8')
diff --git a/aster.install b/aster.install
new file mode 100755
index 000000000000..a3f9a2f6fff3
--- /dev/null
+++ b/aster.install
@@ -0,0 +1,32 @@
+post_install() {
+
+ sed -e "s|#?vers : VVV?|#?vers : VVV?\nvers : STA11.7:/usr/share/aster/STA11.7|" \
+ -i /etc/codeaster/aster
+
+ echo
+ echo " NOTE:"
+ echo " You can launch code-aster from the command-line using"
+ echo " 'as_run *.export' or you can use ASTK interface. In the"
+ echo " latter case - more frequent - you must choose between"
+ echo " rsh and ssh."
+ echo " If you choose ssh, follow"
+ echo " https://wiki.archlinux.org/index.php/Secure_Shell"
+ echo " to install ssh enabling X11 forwarding."
+ echo " Command line astk-ssh launches astk."
+ echo
+}
+
+post_upgrade() {
+ post_remove $1
+ post_install $1
+}
+
+post_remove() {
+ sed -e ':a;N;$!ba;s|\nvers : STA11.7:/usr/share/aster/STA11.7||g' \
+ -i /etc/codeaster/aster
+}
+
+op=$1
+shift
+
+$op $*