summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56d1db2acba5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = astromatic-scamp
+ pkgdesc = computes astrometric and photometric solutions for any arbitrary sequence of FITS images in a completely automatic way.
+ pkgver = 2.0.4
+ pkgrel = 1
+ url = http://www.astromatic.net/software/scamp
+ arch = x86_64
+ license = GPL
+ depends = fftw
+ depends = atlas-lapack
+ depends = astromatic-sextractor
+ depends = cdsclient
+ source = http://www.astromatic.net/download/scamp/scamp-2.0.4.tar.gz
+ sha1sums = 0c81ba051c17adda3b779d06059cec86ab1912dd
+
+pkgname = astromatic-scamp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..669366dfede6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Yigit Dallilar <yigit.dallilar@gmail.com>
+
+pkgname=astromatic-scamp
+_pkgname=scamp
+pkgver=2.0.4
+pkgrel=1
+pkgdesc="computes astrometric and photometric solutions for any arbitrary sequence of FITS images in a completely automatic way."
+url="http://www.astromatic.net/software/scamp"
+arch=('x86_64')
+license=('GPL')
+depends=('fftw' 'atlas-lapack' 'astromatic-sextractor' 'cdsclient')
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+source=(http://www.astromatic.net/download/scamp/scamp-${pkgver}.tar.gz)
+sha1sums=('0c81ba051c17adda3b779d06059cec86ab1912dd')
+
+build() {
+ cd $srcdir/${_pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $srcdir/${_pkgname}-${pkgver}
+ make DESTDIR="$pkgdir" install
+
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}
+