summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 6 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a42309b81813..df23641e8192 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = asus-kbd-backlight
pkgdesc = Helper for adjusting keyboard backlight brightness in Asus Zenbook UX31A and similar models
- pkgver = 1.1
+ pkgver = 1.2
pkgrel = 1
url = https://wiki.archlinux.org/index.php/ASUS_Zenbook_Prime_UX31A#keyboard_backlight_script
install = asus-kbd-backlight.install
diff --git a/PKGBUILD b/PKGBUILD
index 16ac811b8079..31e60fe1cb6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Author: Stefan Majewsky <majewsky at-the-server gmx with-the-tld net>
pkgname=asus-kbd-backlight
-pkgver=1.1
+pkgver=1.2
pkgrel=1
pkgdesc="Helper for adjusting keyboard backlight brightness in Asus Zenbook UX31A and similar models"
url="https://wiki.archlinux.org/index.php/ASUS_Zenbook_Prime_UX31A#keyboard_backlight_script"
@@ -75,13 +75,13 @@ build() {
;;
allowusers)
# Allow members of users group to change brightness
- sudo chgrp users ${path}/brightness
- sudo chmod g+w ${path}/brightness
+ chgrp users ${path}/brightness
+ chmod g+w ${path}/brightness
;;
disallowusers)
# Allow members of users group to change brightness
- sudo chgrp root ${path}/brightness
- sudo chmod g-w ${path}/brightness
+ chgrp root ${path}/brightness
+ chmod g-w ${path}/brightness
;;
*)
commit $1
@@ -96,10 +96,7 @@ build() {
After=systemd-udevd.service
[Service]
- Type=oneshot
- RemainAfterExit=yes
ExecStart=/usr/bin/asus-kbd-backlight allowusers
- ExecStop=/usr/bin/asus-kbd-backlight disallowusers
[Install]
WantedBy=multi-user.target