summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b74f1db3c9e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = async_comm-git
+ pkgdesc = This project provides a C++ library that gives a simple interface for asynchronous serial communications over a serial port or UDP.
+ pkgver = r47.9b83a41
+ pkgrel = 1
+ url = https://github.com/dpkoch/async_comm
+ arch = x86_64
+ license = BSD-3
+ makedepends = git
+ depends = cmake
+ depends = boost
+ source = git+https://github.com/dpkoch/async_comm
+ sha256sums = SKIP
+
+pkgname = async_comm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e30ba911119
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Riccardo Berto <riccardobrt at gmail dot com>
+
+_pkgname=async_comm
+pkgname=async_comm-git
+pkgver=r47.9b83a41
+pkgrel=1
+pkgdesc="This project provides a C++ library that gives a simple interface for asynchronous serial communications over a serial port or UDP."
+arch=('x86_64')
+url="https://github.com/dpkoch/$_pkgname"
+license=('BSD-3')
+depends=('cmake' 'boost')
+makedepends=('git')
+source=("git+$url")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $_pkgname
+ mkdir build && cd build
+ cmake .. && make $MAKEFLAGS
+}
+
+package() {
+ cd $_pkgname
+ install -D build/libasync_comm.so $pkgdir/usr/lib/libasync_comm.so
+ install -Dm644 LICENSE.md $pkgdir/usr/share/licenses/$_pkgname/LICENSE
+}