summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD105
2 files changed, 108 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc08f8bd4725..7a3c4af412bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,44 @@
pkgbase = at-spi2-core-git
pkgdesc = Protocol definitions and daemon for D-Bus at-spi
- pkgver = 2.38.0
+ pkgver = 2.51.90.r33.g066312934
pkgrel = 1
url = https://gitlab.gnome.org/GNOME/at-spi2-core
arch = x86_64
license = GPL2
- makedepends = gobject-introspection
+ checkdepends = at-spi2-core
+ makedepends = dbus-broker
+ makedepends = gi-docgen
makedepends = git
+ makedepends = gobject-introspection
makedepends = meson
+ makedepends = python-sphinx
depends = dbus
depends = glib2
+ depends = gsettings-desktop-schemas
+ depends = libx11
+ depends = libxml2
depends = libxtst
+ depends = systemd
+ depends = xorg-xprop
+ source = at-spi2-core::git+https://gitlab.gnome.org/GNOME/at-spi2-core.git
+ b2sums = SKIP
+
+pkgname = at-spi2-core-git
optdepends = dbus-broker: Alternative bus implementation
provides = at-spi2-core
+ provides = at-spi2-atk=2.51.90.r33.g066312934-1
+ provides = atk=2.51.90.r33.g066312934-1
+ provides = libatk-1.0.so
+ provides = libatk-bridge-2.0.so
+ provides = libatspi.so
conflicts = at-spi2-core
- source = git+https://gitlab.gnome.org/GNOME/at-spi2-core.git
- sha256sums = SKIP
-
-pkgname = at-spi2-core-git
+ conflicts = at-spi2-atk<=2.38.0-2
+ conflicts = atk<=2.38.0-2
+ replaces = at-spi2-atk<=2.38.0-2
+ replaces = atk<=2.38.0-2
+pkgname = at-spi2-core-docs-git
+ pkgdesc = Protocol definitions and daemon for D-Bus at-spi (documentation)
+ depends =
+ provides = at-spi2-core-docs
+ conflicts = at-spi2-core-docs
diff --git a/PKGBUILD b/PKGBUILD
index e5e90e6dd8dc..86d13a3427be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,99 @@
-# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Maintainer: Alexander Epaneshnikov <alex19ep@archlinux.org>
+# Contributor: Vincent Grande <shoober420@gmail.com>
# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
# Contributor: Ionut Biru <ibiru@archlinux.org>
-pkgname=at-spi2-core-git
-pkgver=2.38.0
+pkgbase=at-spi2-core-git
+pkgname=(
+ at-spi2-core-git
+ at-spi2-core-docs-git
+)
+pkgver=2.51.90.r33.g066312934
pkgrel=1
pkgdesc="Protocol definitions and daemon for D-Bus at-spi"
url="https://gitlab.gnome.org/GNOME/at-spi2-core"
arch=(x86_64)
license=(GPL2)
-depends=(dbus glib2 libxtst)
-makedepends=(gobject-introspection git meson)
-optdepends=('dbus-broker: Alternative bus implementation')
-provides=(at-spi2-core)
-conflicts=(at-spi2-core)
-source=("git+https://gitlab.gnome.org/GNOME/at-spi2-core.git")
-sha256sums=('SKIP')
+depends=(
+ dbus
+ glib2
+ gsettings-desktop-schemas
+ libx11
+ libxml2
+ libxtst
+ systemd
+ xorg-xprop
+)
+makedepends=(
+ dbus-broker
+ gi-docgen
+ git
+ gobject-introspection
+ meson
+ python-sphinx
+)
+checkdepends=(
+ at-spi2-core
+)
+source=(${pkgname%-git}::"git+https://gitlab.gnome.org/GNOME/at-spi2-core.git")
+b2sums=('SKIP')
pkgver() {
- cd at-spi2-core
- git describe --tags | sed 's/^AT_SPI2_CORE_//;s/_/./g;s/-/+/g'
+ cd at-spi2-core
+ git describe --long | sed 's/^AT_SPI2_CORE_//;s/\([^-]*-g\)/r\1/;s/_/-/g;s/-/./g'
}
prepare() {
- cd at-spi2-core
+ cd at-spi2-core
}
-
+
build() {
- arch-meson at-spi2-core build -D docs=false
-
- meson compile -C build
+ local meson_options=(
+ -D default_bus=dbus-broker
+ -D docs=true
+ )
+
+ arch-meson at-spi2-core build "${meson_options[@]}"
+ meson compile -C build
+}
+
+check() {
+ dbus-run-session meson test -C build --print-errorlogs
}
-#check() {
- # memory test fails without desktop
- # broker fails to launch without journald
-# dbus-run-session meson test -C build --print-errorlogs || :
-# }
+package_at-spi2-core-git() {
+ optdepends=('dbus-broker: Alternative bus implementation')
+ provides=(
+ "${pkgname%-git}"
+ "at-spi2-atk=$pkgver-$pkgrel"
+ "atk=$pkgver-$pkgrel"
+ libatk-1.0.so
+ libatk-bridge-2.0.so
+ libatspi.so
+ )
+ conflicts=(
+ "${pkgname%-git}"
+ 'at-spi2-atk<=2.38.0-2'
+ 'atk<=2.38.0-2'
+ )
+ replaces=(
+ 'at-spi2-atk<=2.38.0-2'
+ 'atk<=2.38.0-2'
+ )
-package() {
- DESTDIR="$pkgdir" meson install -C build
- }
+ meson install -C build --destdir "$pkgdir"
-# vim:set ts=2 sw=2 et:
+ mkdir -p doc/usr/share
+ mv {"$pkgdir",doc}/usr/share/doc
+}
+
+package_at-spi2-core-docs-git() {
+ pkgdesc+=" (documentation)"
+ provides=("${pkgname%-git}")
+ conflicts=("${pkgname%-git}")
+ depends=()
+
+ mv doc/* "$pkgdir"
+}
+# vim:set sw=2 sts=-1 et: