summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD17
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f0beb5bb58b..bc08f8bd4725 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,7 +8,6 @@ pkgbase = at-spi2-core-git
makedepends = gobject-introspection
makedepends = git
makedepends = meson
- makedepends = dbus-broker
depends = dbus
depends = glib2
depends = libxtst
diff --git a/PKGBUILD b/PKGBUILD
index 69c9106e700a..e5e90e6dd8dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ url="https://gitlab.gnome.org/GNOME/at-spi2-core"
arch=(x86_64)
license=(GPL2)
depends=(dbus glib2 libxtst)
-makedepends=(gobject-introspection git meson dbus-broker)
+makedepends=(gobject-introspection git meson)
optdepends=('dbus-broker: Alternative bus implementation')
provides=(at-spi2-core)
conflicts=(at-spi2-core)
@@ -20,18 +20,17 @@ sha256sums=('SKIP')
pkgver() {
cd at-spi2-core
git describe --tags | sed 's/^AT_SPI2_CORE_//;s/_/./g;s/-/+/g'
- }
+}
prepare() {
cd at-spi2-core
- }
-
+}
+
build() {
- arch-meson at-spi2-core build \
- -D default_bus=dbus-broker \
- -D docs=false
- meson compile -C build
- }
+ arch-meson at-spi2-core build -D docs=false
+
+ meson compile -C build
+}
#check() {
# memory test fails without desktop