summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO43
-rw-r--r--.gitignore1
-rw-r--r--Makefile (renamed from makefile.shared.mt)0
-rw-r--r--PKGBUILD152
-rw-r--r--atlas-license.txt29
-rw-r--r--blas-license.txt19
-rw-r--r--gfortran-10.patch40
-rw-r--r--makefile.shared.st25
8 files changed, 120 insertions, 189 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7efe8658c7c6..1c411d62dbbc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,43 +1,30 @@
-# Generated by mksrcinfo v8
-# Sat Jul 30 16:35:26 UTC 2016
pkgbase = atlas-lapack
- pkgdesc = Complete LAPACK and BLAS implementation using optimised ATLAS routines
+ pkgdesc = Automatically Tuned Linear Algebra Software
pkgver = 3.10.3
- pkgrel = 1
- url = http://math-atlas.sourceforge.net/
+ pkgrel = 9
+ epoch = 1
+ url = http://math-atlas.sourceforge.net
install = atlas-lapack.install
- arch = i686
arch = x86_64
- license = custom:blas
+ license = BSD
license = custom:lapack
- license = custom:atlas
- makedepends = binutils
- makedepends = sed
makedepends = gcc-fortran
depends = gcc-libs
provides = blas
- provides = lapack=3.6.1
+ provides = lapack
provides = cblas
provides = atlas-lapack-base
- conflicts = blas
- conflicts = lapack
- conflicts = cblas
- conflicts = atlas-lapack-base
- noextract = lapack-3.6.1.tgz
+ noextract = lapack-3.12.0.tar.gz
noextract = atlas3.10.3.tar.bz2
options = !makeflags
- source = http://www.netlib.org/lapack/lapack-3.6.1.tgz
+ options = !buildflags
+ source = lapack-3.12.0.tar.gz::https://github.com/Reference-LAPACK/lapack/archive/v3.12.0.tar.gz
source = http://downloads.sourceforge.net/math-atlas/atlas3.10.3.tar.bz2
- source = blas-license.txt
- source = atlas-license.txt
- source = makefile.shared.mt
- source = makefile.shared.st
- md5sums = 421b2cb72e15f237e144428f9c460ee0
- md5sums = d6ce4f16c2ad301837cfb3dade2f7cef
- md5sums = 38b6acb8ed5691d25863319d30a8b365
- md5sums = 4903eb06072dfbf94710691ccb6660bf
- md5sums = e293bf3b62b7cc02cb5dcf54f9f40053
- md5sums = 5153cb945e8f386e4d98d4b0fe791776
+ source = Makefile
+ source = gfortran-10.patch
+ sha256sums = eac9570f8e0ad6f30ce4b963f4f033f0f643e7c3912fc9ee6cd99120675ad48b
+ sha256sums = 2688eb733a6c5f78a18ef32144039adcd62fabce66f2eb51dd59dde806a6d2b7
+ sha256sums = 7627446a0d598b55bc8f2795f8ff2028f134928b9ca597b76bf8dd5622dbff69
+ sha256sums = 33dbb696ab88cf8df2b7fcebbbd60c01b0a26afdd5df4be2d8b344a7bfcdc12f
pkgname = atlas-lapack
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6e92f57d4647
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+tags
diff --git a/makefile.shared.mt b/Makefile
index 048fa456e23b..048fa456e23b 100644
--- a/makefile.shared.mt
+++ b/Makefile
diff --git a/PKGBUILD b/PKGBUILD
index 6b93502caf66..35a403b0d7e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,104 +1,80 @@
-# Maintainer: Giuseppe Borzi <gborzi___AT___ieee___DOT___org>
+# Caretaker: Henk Metselaar <hmetselaar___AT___fastmail___DOT___com>
+# Previous Maintainer: Anton Kudelin <kudelin___AT___protonmail___DOT___com>
+# Contributor: Giuseppe Borzi <gborzi___AT___ieee___DOT___org>
# Contributor: mickele <mimocciola___AT___yahoo___DOT___ com>
# Contributor: iztok pizorn <pizorn___AT___gmail___DOT___com>
# Contributor: olivier medoc <o_medoc___AT___yahoo___DOT___fr>
+
pkgname=atlas-lapack
+_PKGNAME=ATLAS
pkgver=3.10.3
-_lapackver=3.6.1
-pkgrel=1
-pkgdesc="Complete LAPACK and BLAS implementation using optimised ATLAS routines"
-url="http://math-atlas.sourceforge.net/"
+_lapackver=3.12.0
+pkgrel=9
+epoch=1
+pkgdesc="Automatically Tuned Linear Algebra Software"
+url="http://math-atlas.sourceforge.net"
depends=('gcc-libs')
-makedepends=('binutils' 'sed' 'gcc-fortran')
-arch=('i686' 'x86_64')
-conflicts=('blas' 'lapack' 'cblas' 'atlas-lapack-base')
-provides=("blas" "lapack=$_lapackver" 'cblas' 'atlas-lapack-base')
-license=('custom:blas' 'custom:lapack' 'custom:atlas')
-options=(!makeflags)
+makedepends=('gcc-fortran')
+arch=('x86_64')
+provides=('blas' 'lapack' 'cblas' 'atlas-lapack-base')
+license=('BSD' 'custom:lapack')
+source=("lapack-$_lapackver.tar.gz::https://github.com/Reference-LAPACK/lapack/archive/v$_lapackver.tar.gz"
+ "http://downloads.sourceforge.net/math-atlas/atlas$pkgver.tar.bz2"
+ "Makefile"
+ "gfortran-10.patch")
+noextract=("lapack-$_lapackver.tar.gz" "atlas$pkgver.tar.bz2")
+sha256sums=('eac9570f8e0ad6f30ce4b963f4f033f0f643e7c3912fc9ee6cd99120675ad48b'
+ '2688eb733a6c5f78a18ef32144039adcd62fabce66f2eb51dd59dde806a6d2b7'
+ '7627446a0d598b55bc8f2795f8ff2028f134928b9ca597b76bf8dd5622dbff69'
+ '33dbb696ab88cf8df2b7fcebbbd60c01b0a26afdd5df4be2d8b344a7bfcdc12f')
+options=(!makeflags !buildflags)
install=$pkgname.install
-source=(http://www.netlib.org/lapack/lapack-$_lapackver.tgz
- http://downloads.sourceforge.net/math-atlas/atlas${pkgver}.tar.bz2
- blas-license.txt atlas-license.txt
- makefile.shared.mt makefile.shared.st)
-noextract=(lapack-$_lapackver.tgz atlas$pkgver.tar.bz2)
-md5sums=('421b2cb72e15f237e144428f9c460ee0'
- 'd6ce4f16c2ad301837cfb3dade2f7cef'
- '38b6acb8ed5691d25863319d30a8b365'
- '4903eb06072dfbf94710691ccb6660bf'
- 'e293bf3b62b7cc02cb5dcf54f9f40053'
- '5153cb945e8f386e4d98d4b0fe791776')
+prepare() {
+ echo 'Before building this package, as root you must set the CPU(s)'
+ echo 'governor(s) to "performance" and disable intel_pstate.'
+ echo 'See: https://wiki.archlinux.org/index.php/CPU_frequency_scaling'
+ echo "You should also comment out the warning from fgrep, for example as root type sed -i 's/^echo/\\#echo/' /usr/bin/fgrep"
+
+ cd "$srcdir"
+ tar -xjf atlas$pkgver.tar.bz2
+ mkdir -p $_PKGNAME/build
+
+ cd $_PKGNAME
+ patch -p1 < "$srcdir/gfortran-10.patch"
+}
+
build() {
- msg 'Before building this package, as root you must set the CPU(s)'
- msg 'governor(s) to "performance".'
- msg 'See: https://wiki.archlinux.org/index.php/CPU_frequency_scaling'
-
- cd "$srcdir"
- tar -xjf atlas$pkgver.tar.bz2
-
- unset MAKE
- CORE=`cat /proc/cpuinfo | grep "cpu MHz" | head -n 1 | sed "s/.*: \([0-9.]*\).*/\1/"`
- NCPU=`grep "^processor" /proc/cpuinfo | wc -l`
- if [ "$CARCH" = "x86_64" ]; then
- ARCHITECTURE_BUILD_OPTS="-b 64" # for x86_64
- else
- ARCHITECTURE_BUILD_OPTS="-b 32" # for i686
- fi
-
- cd "$srcdir"/ATLAS
- rm -rf build
- mkdir -p build
- cd build
-
- msg 'Configuring ATLAS'
-
- ../configure --prefix=/usr/ $ARCHITECTURE_BUILD_OPTS -Fa alg -fPIC \
- --shared -D c -DPentiumCPS=$CORE \
- --with-netlib-lapack-tarfile="$srcdir/lapack-$_lapackver.tgz"
-
- msg 'Building ATLAS'
-
- make build
-
- msg 'Building shared libraries'
- cd lib
- if [ 1 -lt $NCPU ]; then
- cp "$srcdir/makefile.shared.mt" makefile
- else
- cp "$srcdir/makefile.shared.st" makefile
- fi
- make -f makefile
+ cd "$srcdir/$_PKGNAME/build"
+ ../configure --prefix=/usr \
+ --shared \
+ --with-netlib-lapack-tarfile="$srcdir/lapack-$_lapackver.tar.gz"
+ make build
+ cd lib
+ cp "$srcdir/Makefile" .
+ make
}
check() {
- cd "$srcdir/ATLAS/build"
- unset MAKE
-
- msg 'Checking ATLAS'
-
- make check
- make ptcheck
- make time
+ cd "$srcdir/$_PKGNAME/build"
+ make check F77FLAGS="$F77FLAGS -fallow-argument-mismatch"
+ make ptcheck
+ make time
}
package() {
- cd "$srcdir/ATLAS/build"
- unset MAKE
-
- msg 'Packaging ATLAS'
-
- make DESTDIR="$pkgdir/usr" install
- cp -d lib/*.so* "$pkgdir/usr/lib"
- [ -e lib/libptlapack.a ] && cp lib/libptlapack.a "$pkgdir/usr/lib"
- cd "$pkgdir/usr/lib"
- ln -s libblas.so libblas.so.3
- ln -s liblapack.so.3 liblapack.so
-
- install -Dm644 "${srcdir}/blas-license.txt" \
- "${pkgdir}/usr/share/licenses/$pkgname/blas-license.txt"
- install -Dm644 "${srcdir}/ATLAS/build/src/lapack/reference/LICENSE" \
- "${pkgdir}/usr/share/licenses/$pkgname/lapack-license.txt"
- install -Dm644 "${srcdir}/atlas-license.txt" \
- "${pkgdir}/usr/share/licenses/$pkgname/atlas-license.txt"
+ cd "$srcdir/$_PKGNAME/build"
+ make DESTDIR="$pkgdir/usr" install
+ cp -d lib/*.so "$pkgdir/usr/lib"
+ install -m755 lib/liblapack.so.3.6.1 "$pkgdir/usr/lib/liblapack.so.$_lapackver"
+ install -m755 lib/libptlapack.so.3.6.1 "$pkgdir/usr/lib/libptlapack.so.$_lapackver"
+ cd "$pkgdir/usr/lib"
+ ln -s liblapack.so.$_lapackver liblapack.so.3
+ ln -s liblapack.so.3 liblapack.so
+ ln -s libblas.so libblas.so.3
+ ln -s libcblas.so libcblas.so.3
+ cd ../include/atlas
+ sed -i "s#$srcdir# #g" *
+ install -Dm644 "$srcdir/$_PKGNAME/build/src/lapack/reference/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/lapack-license.txt"
}
-
diff --git a/atlas-license.txt b/atlas-license.txt
deleted file mode 100644
index 18e3a60e237f..000000000000
--- a/atlas-license.txt
+++ /dev/null
@@ -1,29 +0,0 @@
- Automatically Tuned Linear Algebra Software v3.8.2
- (C) Copyright 1999 R. Clint Whaley
-
- Code contributers : R. Clint Whaley, Antoine P. Petitet
-
- Redistribution and use in source and binary forms, with or without
- modification, are permitted provided that the following conditions
- are met:
- 1. Redistributions of source code must retain the above copyright
- notice, this list of conditions and the following disclaimer.
- 2. Redistributions in binary form must reproduce the above copyright
- notice, this list of conditions, and the following disclaimer in the
- documentation and/or other materials provided with the distribution.
- 3. The name of the ATLAS group or the names of its contributers may
- not be used to endorse or promote products derived from this
- software without specific written permission.
-
- THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
- ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
- TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
- PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE ATLAS GROUP OR ITS CONTRIBUTORS
- BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
- CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
- SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
- INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
- CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
- ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
- POSSIBILITY OF SUCH DAMAGE.
-
diff --git a/blas-license.txt b/blas-license.txt
deleted file mode 100644
index 79f38386e651..000000000000
--- a/blas-license.txt
+++ /dev/null
@@ -1,19 +0,0 @@
-From: http://www.netlib.org/blas/faq.html
-
- 2) Are there legal restrictions on the use of BLAS reference
- implementation software?
-
-The reference BLAS is a freely-available software package. It is
-available from netlib via anonymous ftp and the World Wide Web. Thus,
-it can be included in commercial software packages (and has been). We
-only ask that proper credit be given to the authors.
-
-Like all software, it is copyrighted. It is not trademarked, but we do
-ask the following:
-
-If you modify the source for these routines we ask that you change the
-name of the routine and comment the changes made to the original.
-
-We will gladly answer any questions regarding the software. If a
-modification is done, however, it is the responsibility of the person
-who modified the routine to provide support.
diff --git a/gfortran-10.patch b/gfortran-10.patch
new file mode 100644
index 000000000000..9983d99b0273
--- /dev/null
+++ b/gfortran-10.patch
@@ -0,0 +1,40 @@
+Description: Fix FTBFS with gfortran 10
+Origin: other, https://github.com/Reference-LAPACK/lapack/commit/7fb63b1cd386b099d7da6eeaafc3e7dce055a7d0
+Bug-Debian: https://bugs.debian.org/957015
+Forwarded: no
+Reviewed-by: Sébastien Villemot <sebastien@debian.org>
+Last-Update: 2020-05-20
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/interfaces/blas/C/testing/c_dblat1.f
++++ b/interfaces/blas/C/testing/c_dblat1.f
+@@ -247,11 +247,11 @@
+ IF (ICASE.EQ.7) THEN
+ * .. DNRM2TEST ..
+ STEMP(1) = DTRUE1(NP1)
+- CALL STEST1(DNRM2TEST(N,SX,INCX),STEMP,STEMP,SFAC)
++ CALL STEST1(DNRM2TEST(N,SX,INCX),STEMP(1),STEMP,SFAC)
+ ELSE IF (ICASE.EQ.8) THEN
+ * .. DASUMTEST ..
+ STEMP(1) = DTRUE3(NP1)
+- CALL STEST1(DASUMTEST(N,SX,INCX),STEMP,STEMP,SFAC)
++ CALL STEST1(DASUMTEST(N,SX,INCX),STEMP(1),STEMP,SFAC)
+ ELSE IF (ICASE.EQ.9) THEN
+ * .. DSCALTEST ..
+ CALL DSCALTEST(N,SA((INCX-1)*5+NP1),SX,INCX)
+--- a/interfaces/blas/C/testing/c_sblat1.f
++++ b/interfaces/blas/C/testing/c_sblat1.f
+@@ -247,11 +247,11 @@
+ IF (ICASE.EQ.7) THEN
+ * .. SNRM2TEST ..
+ STEMP(1) = DTRUE1(NP1)
+- CALL STEST1(SNRM2TEST(N,SX,INCX),STEMP,STEMP,SFAC)
++ CALL STEST1(SNRM2TEST(N,SX,INCX),STEMP(1),STEMP,SFAC)
+ ELSE IF (ICASE.EQ.8) THEN
+ * .. SASUMTEST ..
+ STEMP(1) = DTRUE3(NP1)
+- CALL STEST1(SASUMTEST(N,SX,INCX),STEMP,STEMP,SFAC)
++ CALL STEST1(SASUMTEST(N,SX,INCX),STEMP(1),STEMP,SFAC)
+ ELSE IF (ICASE.EQ.9) THEN
+ * .. SSCALTEST ..
+ CALL SSCALTEST(N,SA((INCX-1)*5+NP1),SX,INCX)
diff --git a/makefile.shared.st b/makefile.shared.st
deleted file mode 100644
index 5feda573104c..000000000000
--- a/makefile.shared.st
+++ /dev/null
@@ -1,25 +0,0 @@
-include Make.inc
-
-all: libatlas.so libf77blas.so libcblas.so libblas.so liblapack.so.3.6.1
-
-libatlas.so: libatlas.a
- ld $(LDFLAGS) -shared -soname $@ -o $@ --whole-archive libatlas.a \
- --no-whole-archive -lc $(LIBS)
-
-libf77blas.so : libf77blas.a libatlas.so
- ld $(LDFLAGS) -shared -soname libblas.so.3 -o $@ --whole-archive \
- libf77blas.a --no-whole-archive $(F77SYSLIB) -L. -latlas
-
-libcblas.so : libcblas.a libatlas.so libblas.so
- ld $(LDFLAGS) -shared -soname $@ -o $@ --whole-archive libcblas.a \
- -L. -latlas -lblas
-
-libblas.so: libf77blas.so
- ln -s $< $@
-
-liblapack.so.3.6.1 : liblapack.a libcblas.so libblas.so
- ld $(LDFLAGS) -shared -soname liblapack.so.3 -o $@ --whole-archive \
- liblapack.a --no-whole-archive $(F77SYSLIB) -L. -lcblas -lblas
-
-liblapack.so.3: liblapack.so.3.6.1
- ln -s $< $@